Error in squirrelmail redirect

Discussion in 'Installation/Configuration' started by plucchetti, Oct 19, 2006.

  1. plucchetti

    plucchetti New Member

    I've installed squirrelmail from .pgk.
    I can login into squirrelmail through https://domain.tl:81/squirrelmail/src/login.php and it works fine.
    I created "webmail" and "mail" records in dns manager and webmail.domain.tld and mail.domain.tld subdomains both whit redirect to https://domain.tl:81/squirrelmail/src/login.php.
    When put in browser http://mail.domain.tld i can reach squirrelmail login page without logo and i can't login into webmail nothing occurs, the page remains the same (login page).

    Any idea?

    Thanks in advance.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Right-click on the missing image and go to Properties. What image URL is it trying to load?
     
  3. plucchetti

    plucchetti New Member

    Yes, the file is sm_logo.png an instead image apperar the next text: SquirrelMail Logo



    Thnaks,
    Pablo
     
  4. plucchetti

    plucchetti New Member

  5. falko

    falko Super Moderator ISPConfig Developer

    Does mydomain.tld point to your server? Does the image exist on the server?
     
  6. plucchetti

    plucchetti New Member

    Yes Falko,

    The domain is hosted in the same server.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    And does it point to your server, i.e., is its DNS record ok?
    You can check with the dig command.

    Does the image exist?
     
  8. plucchetti

    plucchetti New Member

    Yes, results of dig command are Ok.

    This is a redirect rule un apacheconf.

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^webmail\.myowndomain\.com\.ar [NC]
    RewriteRule ^/(.*) https://mydomain.tld.com.ar:81/squirrelmail/src/login.php/$1 [L,R]
     
  9. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    I use mail.domain.tld as "co domain" domain.tld and set redirect to 81 port and that works, try that.
     
  10. wr19026

    wr19026 New Member

    Very strange. I host 3 websites on my server. For all of them I have created the co-domain webmail. etc. .tld and created the forward (using the panel) to https://www. etc. .tld:81/squirrelmail/src/login.php

    For 2 of the 3 domains this works; the other refuses to do this. I have ticked the "Create DNS" option for all of them.

    The weird thing is that the full path, when entered, does work?!?!

    The only difference is that I own the 2 working domains whereas the 1 that does not work is forwarded to my server from another ISP; could that be causing the problem?
     
  11. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

  12. wr19026

    wr19026 New Member

    Your problem is in the redirect path, instead of redirecting to ../login.php, just redirect to /squirrelmail

    The problem is that the redirect seems to automatically add a / at the end and ../login.php/ just does not seem to work right ;)

    Falko/Till, is this standard behaviour for redirects or is this a minor bug?
     
  13. falko

    falko Super Moderator ISPConfig Developer

    The forwarding feature is meant for forwarding to a different directory, not file, that's why we have the / at the end. Maybe we can change that.
     
  14. wr19026

    wr19026 New Member

    Any change of this being changed in a future release? I had it working before but now that I reinstalled I can't figure out the easy way to do this redirect anymore....

    Luckily almost everything else was pretty well documented so it didn't take me too much time to do a full reinstall of the server with security etc :)
     
  15. falko

    falko Super Moderator ISPConfig Developer

Share This Page