error in phpmyadmin

Discussion in 'Server Operation' started by pchulpje_net, Jan 31, 2008.

  1. pchulpje_net

    pchulpje_net New Member

    hey all on how to forge,

    i am a recently new to linux on servers, altough i have played a lot white it on virtual pc. somethings are new to me..

    so is this problem that i have white phpmyadmin..
    i have installed ispConfig and everything works perfectly!!, i have also added my website to it and i can install the cms application. bud in phpmyadmin i see a strange error.

    and because i am planning to host costumer websites on it, i want to fix this.

    the error that i get is : Your PHP MySQL library version 4.0.24 differs from your MySQL server version 5.0.22. This may cause unpredictable behavior.

    i have search the internet to a answer bud, it looks like i am the only one white this problem or i do not search good enough..

    i think that i need to update the php mysql library files, bud i don't know how to do that.

    My server configuration is as follows :

    OS : ubuntu Dapper Drake 6.06 (LTS)
    PHP: 5.1.2
    Mysql :5.0.22
    PHP mysql library : 4.0.24
    ISPConfig : 2.2.19


    any help is a welcome!

    regards in advance,
    Jeroenvd
     
    Last edited: Jan 31, 2008
  2. falko

    falko Super Moderator

  3. pchulpje_net

    pchulpje_net New Member

    hey, yes i have followed that, and have done exactly what's in it.

    i have found a another topic on this forum, who has the same problem : http://www.howtoforge.com/forums/archive/index.php/t-15482.html

    the problem that i have is that: when i login to phpmyadmin i see the text : Your PHP MySQL library version 4.0.24 differs from your MySQL server version 5.0.22. This may cause unpredictable behavior.

    in the topic that i have found, stands that the problem the mysql-client is..and that there are no update's any more are for ubuntu 6.06. Bud is it not possible to solve this problem by a certain way ?

    anyway thnx for yout help!


    best regards,
    Jeroenvd
     
  4. topdog

    topdog HowtoForge Supporter

    The issue is you are using a 4.x.x client to connect to a 5.x.x server you need to upgrade your client. You will possibly have to build your own client, anyway why are you using an OS that is not supported any more.
     
  5. pchulpje_net

    pchulpje_net New Member

    sorry for the late post, bud you have right..about the unsupported os. So i have installed yesterday Debian 4.0.

    all problems with ubuntu are gone now..:)


    regards,
    Jeroenvd
     

Share This Page