error in apache log

Discussion in 'General' started by cruz, Apr 30, 2008.

  1. cruz

    cruz New Member

    I am having trubble on my website. Pleple are getting 404 errors when trying to register. So I went to the apache log file and I see this error.
    HTML:
    [Tue Apr 29 21:26:30 2008] [error] [client 192.168.1.199] File does not exist: /var/www/sharedip/TEADevInfo
    [Tue Apr 29 21:26:35 2008] [error] [client 192.168.1.198] File does not exist: /var/www/sharedip/HNAP1
    [Tue Apr 29 21:26:44 2008] [error] [client 192.168.1.198] File does not exist: /var/www/sharedip/TEADevInfo
    [Tue Apr 29 21:46:36 2008] [error] [client 192.168.1.199] File does not exist: /var/www/sharedip/HNAP1
    [Tue Apr 29 21:46:39 2008] [error] [client 192.168.1.199] File does not exist: /var/www/sharedip/TEADevInfo
    [Tue Apr 29 21:46:40 2008] [error] [client 192.168.1.198] File does not exist: /var/www/sharedip/HNAP1
    [Tue Apr 29 21:46:43 2008] [error] [client 192.168.1.198] File does not exist: /var/www/sharedip/TEADevInfo
    
    I can log into the site as a user and I can log into the admin area, but when someone tries to regester they get the error. I ran ls -la /var/lib/php5
    and came up with this.
    HTML:
    drwx-wx-wt  2 root     root      4096 2008-04-29 22:01 .
    drwxr-xr-x 30 root     root      4096 2008-02-01 15:28 ..
    -rw-------  1 www-data www-data 22157 2008-04-29 21:38 sess_5a4c5cce0abf2aa7d550                ec8c1364b251
    -rw-------  1 www-data www-data 22000 2008-04-29 22:01 sess_634e0955172fdff50c8f                cf593ae0fcbe
    
     
  2. falko

    falko Super Moderator ISPConfig Developer

    So you mean you're always getting the Shared-IP page?
    What's in Vhosts_ispconfig.conf, and what's the output of
    Code:
    ifconfig
    ?
     
  3. cruz

    cruz New Member

    ifconfig results

    Here is the ifconfig results.
    HTML:
    server1:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:01:80:5F:F0:4A
              inet addr:192.168.1.155  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::201:80ff:fe5f:f04a/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:11895411 errors:1 dropped:0 overruns:0 frame:1
              TX packets:4108402 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:1035475328 (987.5 MiB)  TX bytes:430402195 (410.4 MiB)
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:12861 errors:0 dropped:0 overruns:0 frame:0
              TX packets:12861 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:4649855 (4.4 MiB)  TX bytes:4649855 (4.4 MiB)
    
    
    Here is what is in the vhost_ispconfig.conf file pertaining to that site.
    ISPConfig vHost Configuration File
    # Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.1.155:80
    <VirtualHost 192.168.1.155:80>
    ServerName localhost
    ServerAdmin [email protected]
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.apostolichearts.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.155:80>
    SuexecUserGroup web1_u1 web1
    ServerName www.apostolichearts.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web1/web
    ServerAlias apostolichearts.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #
     
    Last edited: May 1, 2008
  4. cruz

    cruz New Member

    error message from source

    Here is the error message after trying to register on the site from the page source.
    HTML:
    <HTML>
    <HEAD>
    <TITLE>404 Error - File not found!</TITLE>
    </HEAD>
    <BODY BGCOLOR="#FFFFFF" leftMargin=0 topMargin=0 rightMargin=0 marginheight="0" marginwidth="0">
    <CENTER>
    <TABLE BORDER="0" WIDTH="100%" CELLSPACING="0">
      <TR>
        <TD BGCOLOR="#025CCA" ALIGN="CENTER">
        <HR SIZE="1" COLOR="#FFFFFF">
        <TABLE>
          <TR>
    
            <TD><FONT SIZE="3" COLOR="#FFFFFF" FACE="Helvetica, Arial"><B>404 Error - File not found!</B></FONT></TD>
          </TR>
        </TABLE>
        <HR SIZE="1" COLOR="#FFFFFF">
        </TD>
      </TR>
        <TR>
      <TD><BR><BR><BR>
    
      <CENTER><FONT COLOR="#000000" SIZE="2" FACE="Helvetica, Arial"><B><U>The following error occurred:</U></B></FONT></CENTER>
      <BR></TD>
      </TR>
      <TR>
        <TD BGCOLOR="#FFFFFF">
          <CENTER>
              <FONT COLOR="#000000" SIZE="2" FACE="Helvetica, Arial">The requested URL was not found on this server.
              <P>Please check the URL or contact the  Webmaster.</FONT>
    
          </CENTER>
          <BR>
          <HR SIZE="1" WIDTH="90%">
          <CENTER>
    <FONT SIZE="1" COLOR="#000000" FACE="Verdana, Arial">powered by <A HREF="http://www.ispconfig.org">ISPConfig</A></FONT>
          </CENTER>
        </TD>
      </TR>
    
    </TABLE>
    </CENTER>
    </BODY>
    </HTML>
     
  5. falko

    falko Super Moderator ISPConfig Developer

    I'm not seeing the Shared-IP page when I go to apostolichearts.com...
     
  6. cruz

    cruz New Member

    trubble on registration

    It only happens when you try to register on the site. You put all the info in and when you hit the button to register it comes up with the error page above. I looked in the admin area of the website and it is not registering any info on the person that has tried to register. What is funny is that I can register on my other site that i have setup on the server that is running drupal and it works. I contacted the people that created the script and they told me it was a server issue.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Make sure that the files that are referenced in the action parameter of the <form> tags really exist.
     

Share This Page