Error in access.log...lzf.so

Discussion in 'Installation/Configuration' started by schmidtedv, Jul 29, 2008.

  1. schmidtedv

    schmidtedv New Member

    I guess, I'm missing something belonging to the lzf-module. Can anybody tell me, what to install to get rid of that message:

    Code:
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/lzf.so' - /usr/lib/php5/20060613+lfs/lzf.so: cannot open shared object file: No such file or directory in Unknown on line 0
    
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of:

    ls -la /usr/lib/php5/20060613+lfs/lzf.so
     
  3. schmidtedv

    schmidtedv New Member

    Ok, mein fehler, hatte meine alte php.ini nach dem erneuten "Perfect Setup" übernummen. die war mit lzf aber schon erweitert...mein Log sieht nun so aus:

    Code:
    [Sun Jul 27 11:36:15 2008] [notice] Graceful restart requested, doing restart
    [Sun Jul 27 11:36:15 2008] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/lzf.so' - /usr/lib/php5/20060613+lfs/lzf.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [Sun Jul 27 11:36:16 2008] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch11 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
    [Sun Jul 27 11:36:16 2008] [warn] long lost child came home! (pid 26600)
    [Tue Jul 29 02:18:00 2008] [error] [client 74.63.66.236] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
    [Tue Jul 29 03:08:57 2008] [error] [client 85.114.133.88] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
    [Tue Jul 29 10:29:31 2008] [notice] caught SIGTERM, shutting down
    [Tue Jul 29 10:29:33 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    PHP Warning:  Module 'json' already loaded in Unknown on line 0
    [Tue Jul 29 10:29:34 2008] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch11 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations
    [Tue Jul 29 10:34:09 2008] [notice] caught SIGTERM, shutting down
    [Tue Jul 29 10:34:11 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 29 10:34:12 2008] [notice] Apache/2.2.3 (Debian) PHP/5.2.0-8+etch11 mod_ssl/2.2.3 OpenSSL/0.9.8c configured -- resuming normal operations

    eine Frage bezüglich des json-Modules. Ich bin, wie gesagt frisch durchs Perfect Debian Etch durch...lasse ich json.so in der php.ini stehen wirds scheinbar 2mal geladen. Ist es ok, das ich es daher in der php.ini entferne oder wo kann ich sonst schauen, warum und von was/wem es schon geladen ist?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Meistens gibt es da ein Verzeichnis mit dem Namen wie conf.d. Es liegt dort, wo auch die php.ini liegt. Dieses Verzeichnis enthält dateien für Module, die geladen werden sollen, diese Dateien werden automatisch in die php.ini included.

    Sorry, mixed up the de / enforums :) Here is the english translation:

    Normally there should be a directory conf.d within the directory of the php.ini file. This directory contains configuration snippets for mudules which were included in php.ini automatically.

    @schmidtedv: please post in english if possible or use the german forum if you prefer to post in german :)
     
    Last edited: Jul 29, 2008
  5. schmidtedv

    schmidtedv New Member

    ...sorry :)

    ok, well, i changed my php.ini now and have memcache.ini and imagick.ini as seperated modules in conf.d (looks cleaner now and i know, where to look in future). however, there is no json.ini, this module has to be loaded somewhere else (still an error, when loading it over php.ini)?


    Nevertheless, all logs seem to be ok. Only clamav is complaining

    Code:
    ul 29 09:32:07 217-20-117-95 freshclam[3068]: Current functionality level = 31, recommended = 33 
    Jul 29 11:11:08 217-20-117-95 freshclam[3222]: Your ClamAV installation is OUTDATED! 
    Jul 29 11:11:08 217-20-117-95 freshclam[3222]: Local version: 0.93.1 Recommended version: 0.93.3 
    Jul 29 11:11:09 217-20-117-95 freshclam[3222]: getfile: Unknown response from remote server (IP: 213.174.32.130) 
    Jul 29 11:11:09 217-20-117-95 freshclam[3222]: getpatch: Can't download daily-7875.cdiff from database.clamav.net 
    ...but this belongs to next ISPConfig-Update, I guess :)

    I tried to put deb http://ftp.de.debian.org/debian-volatile/ etch/volatile main in sources.list to get clamav updated...but it seems to be not configurable by this...am i right?
     
    Last edited: Jul 29, 2008
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  7. schmidtedv

    schmidtedv New Member

    Ok, thx...any idea, where json might be loaded then?
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Have you tried to coment out extension=json.so in php.ini?
     
  9. schmidtedv

    schmidtedv New Member

    shure...no error then...reactivation will bring up the error again. so, what i did is just leaving it oud by guessing, json.so will be loaded automatically but from somewhere else the in php.ini or json.ini... ?
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, it's loaded from some other file (not sure which one though).
     
  11. schmidtedv

    schmidtedv New Member

    ok, who cares...its there and thats enough...
     

Share This Page