Error "GD Image Filtering Low Quality / Poor Performance"

Discussion in 'Installation/Configuration' started by panthe, Feb 1, 2010.

  1. panthe

    panthe New Member

    Hi guy,
    I've a machine with Ubuntu 9.10 Desktop.
    I'm developing a drupal site but in the report I've these error messages:

    GD Image Filtering Low Quality / Poor Performance
    The installed version of PHP GD does not support image filtering(desaturate, blur, negate, etc). It was probably compiled using the official GD libraries from http://www.libgd.org instead of the GD library bundled with PHP. You should recompile PHP --with-gd using the bundled GD library. See http://www.php.net/manual/en/image.setup.php. An implementation of imagefilter in PHP will be used in the interim.

    GD Image Rotation Low Quality / Poor Performance
    The installed version of PHP GD does not support image rotations. It was probably compiled using the official GD libraries from http://www.libgd.org instead of the GD library bundled with PHP. You should recompile PHP --with-gd using the bundled GD library. See: http://www.php.net/manual/en/image.setup.php. An implementation of imagerotate in PHP will used in the interim.

    I've follow a guide that say that the problem is that the people who build Ubuntu (and Debian) distribution do not want to compile PHP5 with the version of GD that comes bundled with PHP5.
    Link of guide -> http://cumu.li/2008/5/13/recompiling-php5-with-bundled-support-for-gd-on...

    But after that guide never for me is changed, can someone help me?

    Thanks
    panthe
     
  2. falko

    falko Super Moderator ISPConfig Developer

    How did you install PHP5? Did you use the Ubuntu packages?
     
  3. panthe

    panthe New Member

    Error "GD Image Filtering Low Quality / Poor Performance"

    Hi,
    thanks for your reply.
    Yes, I've used the official ubuntu package php5-gd, after that I've seen in the status report that problem.

    I begin to search on the net for solve it and this is a known bug in launchpad
    https://bugs.launchpad.net/ubuntu/ source/php5/ bug/74647

    Further that I've found a guide that say that the problem is that the people who build Ubuntu (and Debian) distribution do not want to compile PHP5 with the version of GD that comes bundled with PHP5.
    Link of guide -> http://cumu.li/2008/5/13/recompiling-php5-with-bundled-support-for-gd-on

    I don't know how fix it because for me this guide not work...
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. panthe

    panthe New Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Where exactly are you having issues with this guide? Do you get any error messages?
     
  7. the_g_bomb

    the_g_bomb New Member

  8. panthe

    panthe New Member

    Error "GD Image Filtering Low Quality / Poor Performance"

    Hi,
    I've just follow these guides but now I've found where I've put my error...
    Here:

    cd /usr/src
    apt-get install build-essential debhelper fakeroot
    apt-get source php5
    apt-get install build-dep php5
    cd php5-5.2.6.dfsg.1/
    nano debian/rules

    Find and replace

    [...]
    --with-gd=shared,/usr --enable-gd-native-ttf \
    [...]

    with

    [...]
    --with-gd=shared, --enable-gd-native-ttf \
    [...]

    I've put this string

    --with-gd=shared --enable-gd-native-ttf \

    without the ',' after --with-gd=shared

    and when I launch the command
    dpkg-buildpackage -rfakeroot

    I've seen many errors.

    But now I can't recompile all because when I launch this command:
    dpkg-buildpackage -rfakeroot

    I can view this message and some errors too that say me that I can't access at this temporary files ./sedRMjg5U:

    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CPPFLAGS to default value:
    dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    dpkg-buildpackage: source package php5
    dpkg-buildpackage: source version 5.2.10.dfsg.1-2ubuntu6.4
    dpkg-buildpackage: source changed by Marc Deslauriers <[email protected]>
    dpkg-buildpackage: host architecture i386
    fakeroot debian/rules clean
    dh_testdir
    sed -i -e 's/EXTRA_VERSION="-2ubuntu6.4"/EXTRA_VERSION=""/' configure.in
    sed: impossibile aprire il file temporaneo ./sedRMjg5U: Permesso negato
    make: *** [unprepared] Errore 4
    dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2


    Do you have some suggest for me?
    Thanks
    panthe
     
  9. panthe

    panthe New Member

    Error "GD Image Filtering Low Quality / Poor Performance"

    If useful... ;-)

    php -r "var_dump(function_exists('imagerotate'));"
    bool(false)
    Segmentation fault
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Do you run
    Code:
    dpkg-buildpackage -rfakeroot
    as root?
     
  11. panthe

    panthe New Member

    Error "GD Image Filtering Low Quality / Poor Performance"

    No, I've run this command not as sudo user.

    But now I've run as sudo user and this is the error that appears:

    sudo dpkg-buildpackage -rfakeroot

    dpkg-buildpackage: warning: using a gain-root-command while being root
    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CPPFLAGS to default value:
    dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    dpkg-buildpackage: source package php5
    dpkg-buildpackage: source version 5.2.10.dfsg.1-2ubuntu6.4
    dpkg-buildpackage: source changed by Marc Deslauriers <[email protected]>
    dpkg-buildpackage: host architecture i386
    fakeroot debian/rules clean
    dh_testdir
    sed -i -e 's/EXTRA_VERSION="-2ubuntu6.4"/EXTRA_VERSION=""/' configure.in
    rm -f prepared-stamp
    QUILT_PATCHES=debian/patches quilt --quiltrc /dev/null pop -a -R || test $? = 2
    Patch suhosin.patch does not remove cleanly (refresh it or enforce with -f)
    make: *** [unpatch] Errore 1
    dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
     
  12. falko

    falko Super Moderator ISPConfig Developer

Share This Page