Error during an update ...

Discussion in 'Installation/Configuration' started by yoplait, Jan 1, 2010.

  1. yoplait

    yoplait Member

    Hi there,
    I'm installing a ispconfig 3 based server.
    Just when I updated (in stable), at the end of the update, I felt on an error :
    /usr/local/ispconfig/server/scripts/ line 18: syntax error near unexpected token `else'
    /usr/local/ispconfig/server/scripts/ line 18: `else'
    Is it normal ? Is the update ok ? (it seems ok)

    edit : the second problem is that, now, SSL seems to don't work for the interface and I felt on that error :
    Une erreur est survenue pendant une connexion à xxxxxxxxx:xxxxxx.
    SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée.
    (Code d'erreur : ssl_error_rx_record_too_long)
    (an error has occured during the connexion to xxxx:xxx.
    SSL received an record which go higher from the maximum authorised length .... bad translated by myself..)

    Thx ! (and happy new year !)

    (version : to
    Last edited: Jan 2, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok, the update was still successsful. The error was in and older versions and has been fixed by the update.

    Regarding the ssl error, as ispconfig does not support ssl on the interface, I guess you have configured this manually and you have to configure it again after the update.
  3. yoplait

    yoplait Member

    thanks for the bug.
    For the SSL, it is an installation from OVH, a "ready to serve" (How can I translate that in english :p ?), so the SSL was done before I use it...

    So, you say SSL doesn't work for this version, there's no way to configure it again ?
    I'm not so good with SSL configuration ... :(

    In the same time, I tried to put an .htaccess for the interface of ISPconfig, but, when I put it in /var/www/ipsconfig, it doesn't do anything. Is it the right place ?

    Thanks for your help.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Compare your install with this FAQ article.

    Most likely you have to add just the lines in step 4 of this article again.

    There is no .htaccess configured for the interface and you should not add this as this might cause security problems.
  5. yoplait

    yoplait Member

    That's awesome, it works great like this :) .
    Thanks a lot ! :)

    I don't understand why a htaccess is a bad thing for the security ... I wanted to protect my ISPconfig access by this way, in addition with the normal login, isn't it good ?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Using .htaccess to set a password is fine. But make sure that you add allow override rules that only passowrd protection is allowed with .htaccess and no other things like overrriding PHP settings.

Share This Page