error core4 new installation help

Discussion in 'Installation/Configuration' started by warrior, Sep 4, 2006.

  1. warrior

    warrior New Member

    Please help me I try to install this nowe and I get this error howe shuld I fix this ????


    checking for re2c... no
    configure: warning: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
    checking for gawk... gawk
    checking for bison... no
    checking for byacc... no
    checking for bison version... invalid
    configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 (found: none).
    checking for flex... lex
    checking for yywrap in -ll... no
    checking lex output file root... ./configure: line 3246: lex: command not found
    configure: error: cannot find output from lex; giving up
    ERROR: Could not configure PHP
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 816: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
     
  2. jjw

    jjw New Member

    I had a similar error last week. I had done an install but I had not used 'The Perfect Install'. If it were me, I would start over with a fresh install following 'The Perfect Install'.
     
  3. warrior

    warrior New Member

    and howe shuld I install this I think I have missing some thing here

    and where shuld I get this re2c 0.9.11 to my fedoracore4 ????

    and I have try to install this 3 times nowe
     
  4. jjw

    jjw New Member

    If you had followed the perfect install, you would have selected the right packages. You are missing some PHP stuff. You could try to upgrade php:
    Code:
    yum upgrade php
    , but I bet there are other packages missing as well.

    But I am a newbie as well. :)
     
  5. warrior

    warrior New Member

    I get this when I try

    Setting up Upgrade Process
    Setting up repositories
    updates-released 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:04
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    Could not find update match for php
    No Packages marked for Update/Obsoletion
     
  6. jjw

    jjw New Member

    I found this on 'The Perfect Instal' page for core 4:

    apt-get install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel

    Did you originally run this?
     
  7. warrior

    warrior New Member

    I´m not shure what you men Did you originally run this?

    I dont nowe but I run php,mysql
     
  8. jjw

    jjw New Member

    ISPConfig depends on certain packages being installed, and Falko has kindly set up a cut and paste way to install Core 4 with the correct packages.

    http://www.howtoforge.com/perfect_setup_fedora_core_4
     
  9. warrior

    warrior New Member

    yes I do that nowe I have missing lot of stof here :)))

    but whitch name shuld I have to this Create the file /etc/pam.d/ftp with the following content ftp.???????
     
  10. jjw

    jjw New Member

    I think you should do all commands as root.
     
  11. warrior

    warrior New Member

    I have do everything nowe after the link and I get the same error howe can I get this to work ???
     
  12. warrior

    warrior New Member

    please can some one help me I cant get this to work I get the samme error

    so I dont nowe howe to fix this I have read the lin k for core4 and I have setup that corect I think

    +--------------------------------------------------------+
    | You now have successfully built and installed the |
    | Apache 1.3 HTTP server. To verify that Apache actually |
    | works correctly you now should first check the |
    | (initially created or preserved) configuration files |
    | |
    | /root/ispconfig/httpd/conf/httpd.conf
    | |
    | and then you should be able to immediately fire up |
    | Apache the first time by running: |
    | |
    | /root/ispconfig/httpd/bin/apachectl start
    | |
    | Or when you want to run it with SSL enabled use: |
    | |
    | /root/ispconfig/httpd/bin/apachectl startssl
    | |
    | Thanks for using Apache. The Apache Group |
    | http://www.apache.org/ |
    +--------------------------------------------------------+
    creating cache ./config.cache
    checking for Cygwin environment... no
    checking for mingw32 environment... no
    checking for egrep... grep -E
    checking for a sed that does not truncate output... /bin/sed
    checking host system type... i686-pc-linux-gnu
    checking target system type... i686-pc-linux-gnu
    checking for gcc... gcc
    checking whether the C compiler (gcc ) works... yes
    checking whether the C compiler (gcc ) is a cross-compiler... no
    checking whether we are using GNU C... yes
    checking whether gcc accepts -g... yes
    checking whether gcc and cc understand -c and -o together... yes
    checking how to run the C preprocessor... gcc -E
    checking for AIX... no
    checking whether ln -s works... yes
    checking if compiler supports -R... no
    checking if compiler supports -Wl,-rpath,... yes
    checking for re2c... no
    configure: warning: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
    checking for gawk... gawk
    checking for bison... no
    checking for byacc... no
    checking for bison version... invalid
    configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 (found: none).
    checking for flex... lex
    checking for yywrap in -ll... no
    checking lex output file root... ./configure: line 3246: lex: command not found
    configure: error: cannot find output from lex; giving up
    ERROR: Could not configure PHP
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 816: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stop s here!
     
  13. till

    till Super Moderator

    The package flex is missing.

    Please install the flex pacakge from your linux distribution.

    In your case:

     
  14. warrior

    warrior New Member

    Thank you for your help nowe :)
    but nowe my php page dont work eny more I only se the chource code howe shuld I get this to work nowe ?????
     
  15. till

    till Super Moderator

    Create a website in ISPConfig where you check the "PHP" checkbox and copy your php scripts to the website root of this newly created website.
     
  16. warrior

    warrior New Member

    But I cant login wht the default user and password admin howe can I login
    or where can I change this info ?????????????
     
  17. warrior

    warrior New Member

    and when I try to go to my phpmyadmin I only se the sourch code so my sql server dont work enny more after I have install this.
    So howe shuld I fix this ????
     
  18. till

    till Super Moderator

    Install the ISPConfig phpmyadmin package.
     
  19. till

    till Super Moderator

    Did you create the database manaully befor you run the ispconfig installer?
     
  20. warrior

    warrior New Member

    yes I do that howe shuld I wright in to the konsole to install phpmyadmin for this ????
     

Share This Page