ERROR: Connection dropped by IMAP server

Discussion in 'Server Operation' started by hstoellinger, Nov 17, 2009.

  1. hstoellinger

    hstoellinger New Member

    Like some other people I get the message "ERROR: Connection dropped by IMAP server" when trying to connect to squirrelmail. Lookign at mail.err I see an entry:
    postfix/trivial-rewrite[16134]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
    as well as
    postfix/trivial-rewrite[16134]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_do mains.cf(0,lock|fold_fix): table lookup problem

    Has anybody got an idea what I might have missed?
    Regards
    H. Stoellinger:mad:
     
  2. falko

    falko Super Moderator

    Are the MySQL details in /etc/postfix/mysql-virtual_domains.cf correct?
     
  3. hstoellinger

    hstoellinger New Member

    /etc/postfix # cat mysql-virtual_domains.cf
    user = mailadmin
    password = xxxxxxxxxx
    dbname = mail
    query = SELECT domain AS virtual FROM domains WHERE domain='%s'

    In "mailadmin" I deliberately left out the underscore ("_"). Where else does "mailadmin" have to be specified?
    Thanks
     
  4. falko

    falko Super Moderator

    And the MySQL user is mailadmin, or is it mail_admin?
     
  5. hstoellinger

    hstoellinger New Member

    Hello Falko,
    It really WAS mailadmin (not mail_admin). However, I have now installed everything afresh. When trying to log-in, I now get the "Unknown user or password incorrect." message (I enter "info@localhost", which is defined this way in the users table of the mail database of Mysql).
    In addition, there are various errors in "mail.info" and "mail.log" respectively.
    "mail.err" is empty. I suppose there are errors in my definitions. In any case I enclose the pertinent snippets of the two files. I would very much appreciate your help - I consider myself a newbie in this complex matter. Thanks in advance - and greetings from Salzburg
     
  6. falko

    falko Super Moderator

    Can you post the errors from your mail log?

    Which tutorial (URL) did you use?
     
  7. hstoellinger

    hstoellinger New Member

    [solved] ERROR: Connection dropped by IMAP Server

    Hello Falko,
    Thanks a lot for your attention (even on a Sunday!). Actually, I must appologize. I went through my definitions and found a couple of errors (typos, wrong access rights, etc.). Everything now works fine. I do have another question, though: I would like messages and prompts to be in German. Could you maybe point me in the right direction? Thanks in advance and - Have a nice Sunday! Regards H. Stoellinger, Salzburg, Austria
     
  8. hstoellinger

    hstoellinger New Member

    Hello again, I have found out how to change the language --- ofcourse, it's under Options...
    I also have changed the config-file accordingly. Sorry for using your time - and thanks again. H. S.
     

Share This Page