Error configuring suPHP mod

Discussion in 'Installation/Configuration' started by cgavin11, Dec 10, 2012.

  1. cgavin11

    cgavin11 New Member

    Trying to follow: http://www.howtoforge.com/perfect-server-centos-6.3-x86_64-apache2-dovecot-ispconfig-3-p4 and when i get to building suPHP mod with:
    ./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=owner --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes

    I get the following error:

    checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
    build directory, or an apr-config file.

    Has anyone got this or seen this?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does /usr/bin/apr-1-config exist?
     
  3. cgavin11

    cgavin11 New Member

    Yes it does exist.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you disable SELinux?
     
  5. comintech

    comintech New Member

    Same problem here

    Hello,
    I have same problem when trying to configure suPHP for compilation, selinux is disabled and /usr/abin/apr-1-config is present.
    Will appreciate any help!
    Thanks!
    Happy holidays!
     

Share This Page