Error code: ssl_error_rx_record_too_long

Discussion in 'General' started by Darkphyre, Aug 11, 2010.

  1. Darkphyre

    Darkphyre New Member


    I am trying to setup the SSL Certificate on a website under ispconfig 3 but I am getting the following error when I try to access the site via https:// in firefox

    The SSL Certificate is fine as it worked under a different web server that did not use ispconfig 3. I have tried manually copying and pasting the contents of the certificate file into the /var/www/website/ssl/website.crt file and restarting apache. I have tried re-enabling the ssl module via a2enmod ssl but it just says that the module is already enabled. My apache 2 ports.conf file looks like this:

    the /var/log/apache2/error.log file is spitting this out whenever I try to visit the site via https but not via http:

    Google doesn't seem to be yielding any answers as to why this is happening.

    Thank you!
    Last edited: Aug 11, 2010
  2. Darkphyre

    Darkphyre New Member

    Okay. I figured it out. I manually had to add the entire SSL Entry to the /etc/apache2/sites-available/ file... But why didn't ispconfig3 do that for me? Does it not do it unless I "create" the certificate through the interface? If I already have an existing certificate I'm going to have to add the ssl config into the .vhost manually? Also, in the SSL tab of a domain in ISPConfig, there really needs to be a SSL Key field for people that created their .key files in a different server....


Share This Page