[error] an unkown filter was not added: PHP

Discussion in 'Installation/Configuration' started by Arien, Aug 11, 2005.

  1. Arien

    Arien New Member

    Hi all!

    I have installed ISPConfig following the Perfect Setup - Debian Sarge guide, but for now I'm having certain problems with my server.

    One of them is this:

    On /var/log/apache2/error.log I see that it's plenty of errors like

    [Thu Aug 11 17:27:37 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 17:27:37 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 17:27:42 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 17:27:42 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 18:27:05 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 18:27:05 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 18:27:52 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 18:27:52 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 18:27:54 2005] [error] an unknown filter was not added: PHP
    [Thu Aug 11 18:27:54 2005] [error] an unknown filter was not added: PHP


    So I wonder if I make any mistake in the guide or just a common problem with apache2 and php4...

    I have googled a bit and found something about:

    "Regardless, you should replace those <Files *.php> with

    AddType application/x-httpd-php .php

    and similarly for .php3 etc."

    But I couldn't see anything of this on php.conf ...

    Can anybody help me?

    Thanks and sorry for my english.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is the PHP module enabled in your Apache?

    Try this:
    Code:
    cd /etc/apache2/mods-enabled
    ln -s /etc/apache2/mods-available/php4.conf php4.conf
    ln -s /etc/apache2/mods-available/php4.load php4.load
    /etc/init.d/apache2 restart
     
  3. Arien

    Arien New Member

    I found this:

    lrwxrwxrwx 1 root root 37 Aug 5 17:35 php4.conf -> /etc/apache2/mods-available/php4.conf
    lrwxrwxrwx 1 root root 37 Aug 5 17:35 php4.load -> /etc/apache2/mods-available/php4.load


    So I suppose the answer is: yes.
     
  4. jysse

    jysse New Member

    Same problem here

    I checked those links and they are ok.

    lrwxrwxrwx 1 root root 37 Aug 8 20:31 php4.conf -> /etc/apache2/mods-available/php4.conf
    lrwxrwxrwx 1 root root 37 Aug 8 20:31 php4.load -> /etc/apache2/mods-available/php4.load


    Jysse

    error.log:

    [Mon Aug 15 08:58:15 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
    [Mon Aug 15 08:58:17 2005] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-15 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
    [Mon Aug 15 08:58:34 2005] [error] an unknown filter was not added: PHP
    [Mon Aug 15 08:58:34 2005] [error] an unknown filter was not added: PHP
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  6. jysse

    jysse New Member

    Yes sure, at least I tried to....One thing is that I can't remember what was my actions in error situation. Made a small mistake (typo) and after that a new install and everything went well. Maybe a fresh install would help ? If I have to I will do it, with some instructions how to do it ?

    Jysse
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I dont think this "[Mon Aug 15 08:58:34 2005] [error] an unknown filter was not added: PHP" is an serious error, it is just a warning. If PHP is working in your sites created in ISPConfig, i recommend not to reinstall your server.
     
  8. jmroth

    jmroth ISPConfig Developer ISPConfig Developer

    [font=verdana, arial, helvetica]PHP Bug #22881 says: (it is not a bug!)

    [/font]
    [font=verdana, arial, helvetica]So, the error message is nothing really bad and maybe ISPConfig should just look closer at the version of Apache and simply not include those lines in the config file... Using both AddType and Filters makes no sense anyway.
    [/font]
     
  9. Bruce

    Bruce New Member

    Disable something in vhosts/Vhosts_ispconfig.conf

    my mistake
     
    Last edited: Nov 15, 2005
  10. Ivan

    Ivan New Member

    [error] an unknown filter was not added: PHP

    I have the same problem, tries:
    ln -s /etc/httpd/mods-available/php5.conf php5.conf
    ln -s /etc/httpd/mods-available/php5.load php5.load
    /etc/init.d/httpd restart
    But the problem I am not solved.

    If he is not bug like solving it to install an application
    My vhost is :
    DocumentRoot /var/www/web33/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web33/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web33/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5

    AddType application/x-httpd-php-source .phps
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    php_admin_value open_basedir /var/www/web33/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web33/phptmp/
    php_admin_value session.save_path /var/www/web33/phptmp/
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web33/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web33/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web33/user/$1/web/$3
    </VirtualHost>
     
    Last edited: Feb 6, 2006
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    As i posted above, this is a warning and not an error. With the next ISPConfig relaese you will be able to select if filters shall be used.

    Some apache 2.x versions need it but other apache 2.x versions throw a warning instaed.
     
  12. PortMan

    PortMan New Member

    I'm running Fedora 5 and Apache 2.2. I have the latest ISPConfig running.

    My error log is full of these messages. Has anything been done to correct this?

    Thanks.
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

Share This Page