Error after upgrading from 3.0.5.4p8

Discussion in 'General' started by Spawnsworth, Mar 3, 2017.

  1. Spawnsworth

    Spawnsworth Member

    Hi,

    I hope someone can help. We have a server with about half a dozen live websites. I ran the ISP Config upgrade script and it updated from version 3.0.5.4p8 to the latest version. At first this appeared to work OK (have done it on other servers) but in face one of the sites was no longer working. We got the following error:

    [Fri Mar 03 14:33:08.677914 2017] [:error] [pid 28095] [client xxx.xx.xx.xxx:56348] SecurityException in Application.cpp:498: Handler not found in configuration
    [Fri Mar 03 14:33:08.677966 2017] [:error] [pid 28095] [client xxx.xx.xx.xxx:56348] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "application/x-httpd-suphp" not found
    [Fri Mar 03 14:33:08.678097 2017] [core:error] [pid 28095] [client xxx.xx.xx.xxx:56348] End of script output before headers: index.php


    I have since rolled back and am wondering if anyone knows what the problem is so I can safely upgrade to the latest version?


    Many thanks,

    Kirk
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your sites still use suphp? Suphp is deprecated, switch the site to php-fcgi or php-fpm and enable the suexec checkbox. This is way faster than suphp and it runs php under the web user like suphp does.
     
    ahrasis likes this.
  3. Spawnsworth

    Spawnsworth Member

    Hi Till,

    suexec is already enable and php-fpm is select but am still getting the same 500 error. I have the upgrade running on a non production server and have tried disabling suphp (Just turns the website in to text) and everything I have Googled so far hasn't fixed the problem. Any other ideas at all?

    Thanks"
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    So this is a problem with a single site? My guess is that the website config is bad, so when it generates a new vhost file (which would use fpm), it renames to .err and rolls back to the old suphp version. See if there's a .err file for this vhost in /etc/apache2/sites-enabled/
     

Share This Page