Error after update to newest version of ispconfig

Discussion in 'Installation/Configuration' started by czdavid, Jun 29, 2015.

  1. czdavid

    czdavid Member

    i got this email from my server after update ispconfig to newest version.
    Subject: Cron <[email protected]>   [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | xargs -n 200 -r -0 rm
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626+lfs/' - /usr/lib/php5/20090626+lfs/ cannot open shared object file: No such file or directory in Unknown on line 0
    What can I do to fix it?

    Thank you.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not related to a ispconfig update. seems as if you installed updates from your linux distribution and the suhosin file is missing now. diable suhostin in in php.
  3. czdavid

    czdavid Member

    Thank you, but I dont understand.

    I need suhosin => it is installed on server, but insnt located at folder /usr/lib/php5/20090626+lfs/ (file
    What can I do to fix this? When I disable suhosin in PHP config it mean that suhosin won't be used?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Suhosin is not used anymore on current php versions and therefor no suhosin package exists when you updated your linux distribtion, If you have an ld version, e.g. php 5.3, then reinstall suhosin. If you have a newer version, then remove the config file that tries to load suhosin.

Share This Page