Error after update to 3.0.5.2

Discussion in 'Installation/Configuration' started by erkan, Mar 29, 2013.

  1. erkan

    erkan New Member

    After updating to ISP Config 3.0.5.2 from 3.0.4.6 I get a 500 internal server error when trying to access my control panel. And when I try to restart Apache I get this error:

    Restarting web server: apache2[Fri Mar 29 20:02:59 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Fri Mar 29 20:02:59 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
    ... waiting [Fri Mar 29 20:03:00 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    [Fri Mar 29 20:03:00 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

    Anyone knows what's wrong?
     
  2. compugraphix

    compugraphix Member HowtoForge Supporter

    You don't have any sites installed

    turn off
    in /etc/hosts.conf

    # Listen 80
    # Listen 443

    then restart (control panel is)
    yourip:8080 or servername:8080

    hope this helps
     
  3. erkan

    erkan New Member

    I do have two sites installed.

    And I don't have the file: /etc/hosts.conf

    I do have: /etc/hosts

    But in that file I don't have Listen 80 or Listen 443.
     
  4. compugraphix

    compugraphix Member HowtoForge Supporter

    sorry my bad /etc/apache2/ports.conf i mean

    and then run /etc/init.d/apache2 restart
     
  5. erkan

    erkan New Member

    I did that but I still get this error message:

    Restarting web server: apache2[Tue Apr 02 20:56:46 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
    ... waiting [Tue Apr 02 20:56:47 2013] [warn] NameVirtualHost *:443 has no VirtualHosts

    And I also installed ISP Config 3.0.5.2 on a new server and it gives me this error message there too.
     
  6. compugraphix

    compugraphix Member HowtoForge Supporter

    You don't have any https sites installed it's just a warning so all is fine.
     

Share This Page