Error Adding Website: "Incorrect date value: '0000-00-00'"

Discussion in 'General' started by supanatral, Aug 10, 2016.

  1. supanatral

    supanatral Member

    When I add a website on my ISPConfig server, I get an error and it won't add the website at all. FYI: ISPConfig is running on Centos 7

    Here are the versions I'm running
    [[email protected] ~]# php -v
    PHP 5.5.38 (cli) (built: Jul 21 2016 12:25:20)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which MySQL version do you use?
  3. concept21

    concept21 Member

    I think your mysql version's default setting restricts the meaningless date format 00-00. You can release this limitation by adding extra option in your mysql.conf.

    Check from the manual by yourself.

    I also hate this meaningless date format 00-00 appearing in most mysql db. They are hard to remove. :mad:
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, the 00-00 date was the old form for "no date set". The problem is just that old mysql versions used it and now they try to prevent that someone uses it. In my opinion, mysql should be so smart to handle it better instead of breaking all the software that as developed for mysql versions before 5.7 and forcing users to switch mysql into the compatibility mode. And yes, it's a lot of hassle to remove the old date format from all software as all the checks that treat 00-00 as no date needs to be recoded and all sored database values have to be converted. ISPConfig 3.1 des not use the old format anymore.
  5. concept21

    concept21 Member

    Is that any existing script which is capable of replacing all 00-00 date by 01-01 in a mysql db?

Share This Page