Error 553 for Set Up Postfix For Relaying Emails Through Another Mailserver

Discussion in 'HOWTO-Related Questions' started by ugach, Jan 25, 2007.

  1. ugach

    ugach New Member

    Falko,

    I have been banging my head to do exactly this. My config is same as your instructions (except I have those lines in my main.cf).

    relayhost = [smtpout.secureserver.net]:3535
    smtp_sasl_auth_enable = yes
    smtp_sasl_security_options =
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

    I was told to also put following by somebody (not godaddy).

    myhostname = mydomain.com
    mydomain = mydomain.com

    I tried that but it did not work so I am again back to mydomain=mhyhost.dyndns.org

    I got the correct passwd in the sasl_passwd file and it has been processed.
    I get following error.

    status=bounced (host smtp.starfieldtech.com[64.202.165.58] said: 553 Sorry, that domain isn't in my list of allowed rcpthosts. (in reply to RCPT TO command))


    Although account it mentions is indeed [email protected] that I use to login on smtp server and it does not have any problem relaying for client on winblows from the same home network using same credentials.

    Here is what I have

    1. Account with godaddy for their secureserver.net smtp server to relay messages.

    2. A Centos machine connected to HOME/NAT DSL connection. I have dyndns setup so there is a virtual domain pointing to my dynamic IP. I cannot have godaddy point my real domain to my dsl as godaddy is hosting webserver for the domain and also their servers would do a good job of holding the mail than my home box.

    I want users on the CENTOS 4 machine to send out mail pretending to be coming out of this godaddy registered domain. (and may be to receive messages for this domain but this is optional if it is too much to ask) Each user does have an account on godaddy mail server.

    I have used same physical setup with my ISP smtp server and that works fine but Not with godaddy. As I see they are using qmail. Would that make any difference? BTW their tech. support has been useless. First they gave wrong information, 2nd they stopped responding to email requests.

    TIA
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried sending emails to various email accounts? Do you get this error message:

    Code:
    status=bounced (host smtp.starfieldtech.com[64.202.165.58] said: 553 Sorry, that domain isn't in my list of allowed rcpthosts. (in reply to RCPT TO command))
    only for a special email address or for all mails you're sending?

    Also, is port 3535 correct?
     
  3. ugach

    ugach New Member

    I have set up two different accounts with godaddy that have the feature to use the relay. I have tried both accounts to send out e-mails to various e-mail addresses, namely @gmail.com, @sbcglobal.net (this is yahoo managed) and and netscape.net (aol). All show the same failure.

    As a test I had setup mozilla thunderbird and outlook on Windows PC using same smtpout credentials using same recipient addresses and the mail goes out fine.

    All e-mails sent out by postfix bounce back. None has reached the destination.

    Yes, they only allow relay on port 80 and port 3535. I have tried both.

    The exact same setup on same hardware has worked fine with my ISP Sbcglobal/yahoo smtp relay so I am confused. Godaddy does use qmail. Will that make any difference? Is this something to do with RCPT TO being not correct? Could it be pop before drop? But godaddy never mentions it anywhere.

    I have also tried populating generic file with mapping as suggested by this site
    http://www.postfix.org/STANDARD_CONFIGURATION_README.html#fantasy
    I have the same user name on local machine as on godaddy account.

    Again the same failure, hence the head banging :-(
     
  4. falko

    falko Super Moderator ISPConfig Developer

    No, that doesn't make a difference.
    Have you tried sending from domains that GoDaddy doesn't know? Maybe they allow sending only from domains managed by them. Anyway, try to contact their support.
     
  5. ugach

    ugach New Member

    no resolution yet

    Falko,

    Called up godaddy support today. The guy was nice, he said I am doing everything correct and he does not know why error 553. My assumption of error 553 is that their smtp server does not know mydomaIn.com ([ am notgetting registeved withmy auth; so it Óays that I do not know mydomain.com. Is this correct? I tried sending e-mail to @godaddy.com while on the phone and even that bounced. fThe supqort guy:is goin^ to chebk with omebody©tomorro— and send reply back. I will update the forum once I get the closure on this issue do others with this issue can also benefit. Thanks fér this ÿonderfuM site.
    am learning a èot here/
     
  6. falko

    falko Super Moderator ISPConfig Developer

    It seems to be a problem with GoDaddy then...
     
  7. ugach

    ugach New Member

    new information

    Falko, You may be correct that godaddy is giving out something wrong but here is what I did. I connected wireshark sniffer and examined the packets. godaddy correctly give give out auth login response to ehlo but my postfix instead of passing login just moves to sending the message. Is there a way to force postfix to use auth login using some parameter in main.cf?

    Here is the pertinent packet capture.

    Simple Mail Transfer Protocol
    Response: 250-AUTH LOGIN PLAIN\r\n
    Response code: 250
    Response parameter: AUTH LOGIN PLAIN
    Response: 250-8BITMIME\r\n
    Response code: 250
    Response parameter: 8BITMIME
    Response: 250 PIPELINING\r\n
    Response code: 250
    Response parameter: PIPELINING

    My postfix just proceeds to Command: Mail From without giving out credentials.

    When I try to connect to yahoo the auth login handshake is done properly between my postfix and yahoo smtp relay server. Here is the response from yahoo.


    Simple Mail Transfer Protocol
    Response: 250-smtp105.sbc.mail.mud.yahoo.com\r\n
    Response code: 250
    Response parameter: smtp105.sbc.mail.mud.yahoo.com
    Response: 250-AUTH LOGIN PLAIN XYMCOOKIE\r\n
    Response code: 250
    Response parameter: AUTH LOGIN PLAIN XYMCOOKIE
    Response: 250-PIPELINING\r\n
    Response code: 250
    Response parameter: PIPELINING
    Response: 250 8BITMIME\r\n
    Response code: 250
    Response parameter: 8BITMIME
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Hm, I think that only GoDaddy can help you with this problem. :(
     
  9. Zoner21

    Zoner21 New Member

    The same problem

    I know that this thread is been unused for almost 2 years, but I'm having the same problem, cannot use godaddy's relay server and receiving the same 553 error.

    Did any of you resolve this problem????

    Thanks
     
  10. falko

    falko Super Moderator ISPConfig Developer

    You can try another relay server, for example some freemailers allow you to use their servers for relaying.
     
  11. ugach

    ugach New Member

    problem solved

    Post after two years! I guessed that the answer was obvious hence nobody except nice site admin responded. I felt stupid did not post my results. Sorry Falko, I should have posted my solution.

    If you dig smtp.godaddy you will get a name of different server. It is starfield something. Use that server in your postfix sasl_password file and your problem will be solved.

    Now anybody knows how to do fetchmail with yahoo/sbcglobal ssl port?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Do you get any errors when you try this? If so, what's in your fetchmailrc?
     

Share This Page