Error 500 - probably .htaccess file problem

Discussion in 'Installation/Configuration' started by codefritz, Jan 10, 2015.

  1. codefritz

    codefritz New Member

    I have just installed a new ISPConfig 3 server under Debian wheezy. Everything works fine, but now I wanted to install a web shop software (called Shopware) but I alwyas get an error 500 when I try to call the install script. If I delete the .htaccess file I can access any file correctly through the webbrowser but with the .htaccess file active I always get the error 500. Below is the content of the .htaccess file:

    P { margin-bottom: 0.21cm; }
    <IfModule mod_rewrite.c>
    RewriteEngine on

    RewriteBase /shop/

    # Https config for the backend
    #RewriteCond %{HTTPS} !=on
    #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    RewriteRule shopware.dll shopware.php
    RewriteRule files/documents/.* engine [NC,L]
    RewriteRule backend/media/(.*) media/$1 [NC,L]

    RewriteCond %{REQUEST_URI} !(\/(engine|files|templates)\/)
    RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/)
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

    # Fix missing authorization-header on fast_cgi installations
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

    # Staging-Rules start
    #SetEnvIf Host "" ENV=staging

    DirectoryIndex index.html
    DirectoryIndex index.php
    DirectoryIndex shopware.php

    # Disables download of configuration
    <Files ~ "\.(tpl|yml|ini)$">
    Deny from all

    # Enable gzip compression
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json

    <IfModule mod_expires.c>
    <Files ~ "\.(jpe?g|png|gif|css|js)$">
    ExpiresActive on
    ExpiresDefault "access plus 1 month"
    FileETag None
    <IfModule mod_headers.c>
    Header append Cache-Control "public"
    Header unset ETag

    # Disables auto directory index
    <IfModule mod_autoindex.c>
    Options -Indexes

    <IfModule mod_negotiation.c>
    Options -MultiViews

    <IfModule mod_php5.c>
    # php_value memory_limit 128M
    # php_value max_execution_time 120
    # php_value upload_max_filesize 20M
    php_flag phar.readonly off
    php_flag magic_quotes_gpc off
    php_flag session.auto_start off
    php_flag suhosin.session.cryptua off
    php_flag zend.ze1_compatibility_mode off

    # AddType x-mapp-php5 .php
    # AddHandler x-mapp-php5 .php
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the error.log of the website, you find it in the log directory of the site. the reason for the 500 error is explained there.

Share This Page