Error 500 on all web sites

Discussion in 'Installation/Configuration' started by Captain, Jan 12, 2011.

  1. Captain

    Captain Member

    Hello!

    HAve a problem with my server.
    When I try to enter on all web sites on my server have 500 error.
    I am tru to restart apache but nothing.
    It is hacking.

    Please help!
     
  2. Captain

    Captain Member

    I try to delete directive
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/var/www/web65/:/tmp/"
    </IfModule>

    And after that all ok.

    Why this directive does not work?
    P.S. Yesterday all work ok with this directive. But today not.
    No updates for php too.


    thnks.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please take a look in the error.log file of this website and post the error log line that you got there for the 500 error.
     
  4. Captain

    Captain Member

    Error.log in website has nothing.
    Apache error.log too.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    That's strange. Maybe it happened because of a high server load. Does the system have enough memory?
     
  6. Captain

    Captain Member

    With memmory all ok. Mem 3GBm used: 300MB buffers: 80MB cache: 2030MB
    CPU usage avr. 50%

    P.S. Today I install suPHP. All work great.
    But have a problem with permision. If user upload image file via web - this image file have 600 permisition by default and this file did not preview on web.
    How I can configure server to do 644 permisition to upload files?

    Thnks.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    I guess you have to change the umask somewhere. What's in /etc/suphp.conf?
     
  8. Captain

    Captain Member

    Yes. Now I am use umask 0022, by default it is 0077

    Now all work great. But question about Apache directive still open. Why it did not work on mod_php5?
     

Share This Page