Error 500 ISPConfig Web Management Interface

Discussion in 'Installation/Configuration' started by c0mput3, Nov 14, 2016.

  1. c0mput3

    c0mput3 New Member HowtoForge Supporter

    Hi

    I was wondering if someone could help me sort out an issue my ISPConfig has developed.
    When trying to reach the ispconfig web management login page,i am presented with a 500 error message.
    I've determine that the issue lays with mod_fcgid, i've comment it out of the /var/www/php-fcgi-scripts/isconfig, restarted apache2
    but when i try to connect to the ISPconfig web management i get presented with the default apache page.

    Has anyone got any suggestions that might help me resolve this issue.

    Linux - Ubunt 16.04.1 x64
    ISPConfig - 3.1.1p1
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which errors do you get in the apache error.log file when the 500 error occurs?
     
    c0mput3 likes this.
  3. c0mput3

    c0mput3 New Member HowtoForge Supporter

    Good Afternoon Till

    I'm seeing the following errors at the bottom of the apache error.log

    [Mon Nov 14 04:22:52.256014 2016] [:error] [pid 14994] python_init: Python version mismatch, expected '2.7.6', found '2.7.12'.
    [Mon Nov 14 04:22:52.256104 2016] [:error] [pid 14994] python_init: Python executable found '/usr/bin/python'.
    [Mon Nov 14 04:22:52.256109 2016] [:error] [pid 14994] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload$
    [Mon Nov 14 04:22:52.256131 2016] [:notice] [pid 14994] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Mon Nov 14 04:22:52.256136 2016] [:notice] [pid 14994] mod_python: using mutex_directory /tmp
    [Mon Nov 14 04:22:52.264699 2016] [ssl:warn] [pid 14994] AH01906: xxxxx.xxxxxxx.xxx:xxxx:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Nov 14 04:22:52.264811 2016] [ssl:error] [pid 14994] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: emailAddress=[email protected],CN=xxxxx.xxxxxxx.xxx,OU=TECHNICAL,O=xxxxx,L=xxxxx,ST=xxxxx,$
    [Mon Nov 14 04:22:52.264819 2016] [ssl:error] [pid 14994] AH02604: Unable to configure certificate xxxxx.xxxxxxx.com:xxxx:0 for stapling
    [Mon Nov 14 04:22:52.269179 2016] [mpm_prefork:notice] [pid 14994] AH00163: Apache/2.4.18 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.12 OpenSSL/1.0.2g configured -- resuming normal opera$
    [Mon Nov 14 04:22:52.269209 2016] [core:notice] [pid 14994] AH00094: Command line: '/usr/sbin/apache2'
    [Mon Nov 14 04:22:59.508283 2016] [fcgid:warn] [pid 15004] (104)Connection reset by peer: [client xxx.xxx.xxx.xxx:64415] mod_fcgid: error reading data from FastCGI server
    [Mon Nov 14 04:22:59.508346 2016] [core:error] [pid 15004] [client xxx.xxx.xxx.xxx:64415] End of script output before headers: index.php
    [Mon Nov 14 04:26:50.181467 2016] [fcgid:warn] [pid 15001] (104)Connection reset by peer: [client xxx.xxx.xxx.xxx:64503] mod_fcgid: error reading data from FastCGI server
    [Mon Nov 14 04:26:50.181545 2016] [core:error] [pid 15001] [client xxx.xxx.xxx.xxx:64503] End of script output before headers: index.php
     
  4. sjau

    sjau Local Meanie Moderator

    There are ssl certs in a vhost that aren't there anymore I think:

    Code:
    [Mon Nov 14 04:22:52.264811 2016] [ssl:error] [pid 14994] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject:
    
    You'll need to find out which vhost is causing the rpoblem.
     
  5. c0mput3

    c0mput3 New Member HowtoForge Supporter

    none of my vhosts have ssl certs
     

Share This Page