error 500 ispconfig admin panel

Discussion in 'Installation/Configuration' started by wiss, Nov 20, 2013.

  1. wiss

    wiss Member

    Hi, after i update some packages; ispconfig interface dont works.

    error.log
    Code:
    Wed Nov 20 01:58:37 2013] [notice] mod_fcgid: call /var/www/ispconfig/index.php with wrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    [Wed Nov 20 01:58:37 2013] [warn] [client 87.216.108.166] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Wed Nov 20 01:58:37 2013] [error] [client 87.216.108.166] Premature end of script headers: index.php
    
    Please, help!!!
     
  2. wiss

    wiss Member

    I runing Ubuntu 10.04 from guide to perfect server... by falco

    Yesterday for solve one problem i was
    Code:
    apt-get install apapache2-suexec-custom
    After this... ispconfig interface error 500

    I uninstall this package and install
    Code:
    apt-get install apapche2-suexec
    But ispconfig not working, error 500.

    suexec log:
    Code:
    [2013-11-20 07:44:27]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
    [2013-11-20 07:44:27]: directory is writable by others: (/var/www/php-fcgi-scripts/ispconfig)
    [2013-11-20 07:44:27]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
    [2013-11-20 07:44:27]: directory is writable by others: (/var/www/php-fcgi-scripts/ispconfig)
    [2013-11-20 07:46:31]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
    
     
  3. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    The error is in the suexec log :)
    It says the directory for the ispconfig fcgi starter (/var/www/php-fcgi-scripts/ispconfig) is writable by others.
    Try:
    Code:
    chmod o-w /var/www/php-fcgi-scripts/ispconfig
    and see if it helps
     
  4. wiss

    wiss Member

    I try but:
    Code:
    [notice] mod_fcgid: call /var/www/ispconfig/index.php with wrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    [Wed Nov 20 10:00:52 2013] [warn] [client 88.12.56.155] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Wed Nov 20 10:00:52 2013] [error] [client 88.12.56.155] Premature end of script headers: index.php
    Code:
    [2013-11-20 10:00:52]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
    
    error 500 in ispconfig panel, same error

    Thanks...
     
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Also same error still in suexec log?

    Have you checked if your php was updated and some functions of the php.ini are no longer supported?
    If you have unsupported entries in the php.ini this will result in those errors you posted.
     
  6. wiss

    wiss Member

    hy.

    php not update; confirmed.

    All mi problems was for suexec... i think.

    Why i check that suexec it's right...?

    Thx.
     
  7. wiss

    wiss Member

    Apache2 error.log:

    Code:
    /var/www/ispconfig/index.php(18633) exit(communication error), terminated by calling exit(), return code: 0
    suexec.log

    Code:
    [2013-11-20 17:33:18]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
    
    Thx
     
  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Try renaming your php.inis to php.ini.save, then restart apache.
    If the problem is gone then, you have problems with your php.ini settings.
    Don't forget to rename the files back after the test (and restart apache once more).
     
  9. wiss

    wiss Member

    i renamed php.ini and restart apache2

    Error continues

    Code:
    [Wed Nov 20 22:22:15 2013] [notice] mod_fcgid: call /var/www/ispconfig/index.php with wrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    [Wed Nov 20 22:22:16 2013] [warn] [client 87.216.108.166] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Wed Nov 20 22:22:16 2013] [error] [client 87.216.108.166] Premature end of script headers: index.php
    
    Code:
    [2013-11-20 22:22:15]: uid: (5003/ispconfig) gid: (5004/ispconfig) cmd: .php-fcgi-starter
    
    Thx
     
  10. wiss

    wiss Member

    Buffff, i solve this...

    first... permissions and owner in /var/www/php-fcgi-scripts/ispconfig

    chmod 755
    chwon ispconfig:ispconfig

    and... second

    edit file .php-fcgi-start in ispcofig folder

    change path to usr/bin/php-cgi

    Thanks at all!!!
     

Share This Page