ERROR 403 - Forbidden!

Discussion in 'Installation/Configuration' started by Kozley, Jun 4, 2011.

  1. Kozley

    Kozley Member

    Hi all!

    I got problem with SMF packages when I try to upload Tinyportal. I get error message: "You cannot download or install new packages because the Packages directory or one of the files in it are not writable!" and I search after solution and found problem that owner permissions is a need but i don't know which owner I need to change so I try with www-data:www-data and I get error page and all files and directives in /web is empty but SMF is still there on website. What can I doing to get work again? I have try change owner to root, administrator and such, not success :(

    I did create folder "temp" in Packages and change permission to 777 but it don't works too.
  2. Kozley

    Kozley Member

    Okay, I got ftp works now but website does still problem.

    I did just change owner permission: web3:www-data

    Any have idea why do it problem?
  3. Kozley

    Kozley Member

    Now website is working! But still problem with package upload and cannot find solution. Any know how to solve this problem with owner permission?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    you use the wrong website settings and permossions. Please reconfigure the website:

    suexec: on
    php mode: php-fcgi

    owner of all files and folders have to be web user and client group of this website.
  5. Kozley

    Kozley Member

    Thank you for reply. Suexec is enable and owner permission is changed and it show the forbidden page :(

    Only web3:www-data is working.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You use the wrong ownerships. As I explained above, the file owner ahs tpo be the web user and client group and not web user and www-data group. Make sure that you changed all folders and files incl. the web folder and that you have set the permissions to e.g. 755 and not 777!
  7. Kozley

    Kozley Member

    Thanks you so much! I trough it was 777 but changed to 755 and change back to rigth owner permission with web3:client0 and the error page is gone. Now it works :)

Share This Page