(Error 107) https://mydomain.com ispconfig 3 debian 6.0 64 bits

Discussion in 'Installation/Configuration' started by S0ft, Jul 22, 2012.

  1. S0ft

    S0ft Member HowtoForge Supporter

    a few days ago I bought an SSL certificate for a domain, what happens is that every time I try to access https://mydomain.com get the error (Error 107)

    anyone can help me = /

    The certificate is only for 1 domain

    https://mydomain.com Error 107 (net :: ERR_SSL_PROTOCOL_ERROR): SSL protocol error.

    https://mydomain.com:8080 Error 107 (net :: ERR_SSL_PROTOCOL_ERROR): SSL protocol error.
    https://mydomain.com/webmail Error 107 (net :: ERR_SSL_PROTOCOL_ERROR): SSL protocol error.
    https://mydomain.com/phpmyadmin Error 107 (net :: ERR_SSL_PROTOCOL_ERROR): SSL protocol error.


    I got a .zip file with this content
    [​IMG]

    [​IMG]


    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): Error de protocolo SSL.

    : ( have someone throw me a cable, please
     
    Last edited: Jul 22, 2012
  2. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hi

    Did you do it like this:

    - in ISPConfig to to SSL tab and generate a certificate.
    - copy the CSR and use it to order the certificate from trusted CA
    - copy the certificate received from CA as well as the root CA (or intermediate, which goes into bundle)

    Also check, that you have SSL enabled within the basic settings tab.

    Also check, that you have the right .key file and if it's not working, try looking into the error.log file, their will most probably be a hint on what's wrong.
     
  3. S0ft

    S0ft Member HowtoForge Supporter

    [​IMG]

    I got a zip file containing 3

    AddTrustExternalCARoot and PositiveSSLCA2
    visualized with the notepad and added to the SSL Bundle



    [​IMG]

    But still not working! I'll see error.log
    HTML:
    [Fri Jul 20 06:37:20 2012] [notice] Apache/2.2.16 (Debian) configured -- resuming normal operations
    [Fri Jul 20 06:37:20 2012] [notice] Graceful restart requested, doing restart
    [Fri Jul 20 06:37:20 2012] [notice] Apache/2.2.16 (Debian) configured -- resuming normal operations
    [Fri Jul 20 06:37:24 2012] [notice] caught SIGTERM, shutting down
    [Fri Jul 20 06:37:26 2012] [notice] Apache/2.2.16 (Debian) configured -- resuming normal operations
    [Fri Jul 20 06:37:26 2012] [notice] Graceful restart requested, doing restart
    [Fri Jul 20 06:37:26 2012] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 configured -- resuming normal operations
    [Fri Jul 20 06:37:26 2012] [notice] child pid 20292 exit signal Segmentation fault (11)
    [Fri Jul 20 06:37:26 2012] [notice] child pid 20294 exit signal Segmentation fault (11)
    [Fri Jul 20 06:37:26 2012] [notice] child pid 20296 exit signal Segmentation fault (11)
    [Fri Jul 20 06:37:26 2012] [notice] child pid 20297 exit signal Segmentation fault (11)
    [Fri Jul 20 06:37:26 2012] [notice] child pid 20298 exit signal Segmentation fault (11)
    [Fri Jul 20 06:37:27 2012] [notice] Graceful restart requested, doing restart
    [Fri Jul 20 06:37:27 2012] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze13 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) configured -- resuming normal operations
    [Fri Jul 20 06:37:27 2012] [notice] child pid 20426 exit signal Segmentation fault (11)
    [Fri Jul 20 06:37:37 2012] [notice] Graceful restart requested, doing restart
    [Fri Jul 20 06:37:37 2012] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze13 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) configured -- resuming normal operations
    [Fri Jul 20 06:37:55 2012] [notice] caught SIGTERM, shutting down
    [Fri Jul 20 06:37:56 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Jul 20 06:37:56 2012] [notice] Digest: generating secret for digest authentication ...
    [Fri Jul 20 06:37:56 2012] [notice] Digest: done
    [Fri Jul 20 06:37:56 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze13 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
    [Fri Jul 20 06:38:20 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 06:50:32 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 06:50:36 2012] [error] [client 190.42.171.185] File does not exist: /var/www/dsd
    [Fri Jul 20 06:50:36 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 06:50:41 2012] [notice] caught SIGTERM, shutting down
    [Fri Jul 20 06:50:42 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Jul 20 06:50:42 2012] [notice] Digest: generating secret for digest authentication ...
    [Fri Jul 20 06:50:42 2012] [notice] Digest: done
    [Fri Jul 20 06:50:42 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze13 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
    [Fri Jul 20 06:51:32 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 06:55:45 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 06:55:48 2012] [error] [client 190.42.171.185] File does not exist: /var/www/we
    [Fri Jul 20 06:55:48 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 06:55:51 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 07:01:01 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 07:03:00 2012] [error] [client 190.42.171.185] File does not exist: /var/www/favicon.ico
    [Fri Jul 20 07:03:02 2012] [notice] caught SIGTERM, shutting down
    

    how realize as if the certificate is working on my server?
     
    Last edited: Jul 22, 2012
  4. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hmm

    error.log doesn't contain any information on it (what I see).

    The cert is for the domain your opening? As it looks in the screen, it's only for www.domain.tld and you're trying to access it without www.

    Can you also post the content of /etc/apache2/sites-enabled/100-domain.tld.vhost
     
  5. S0ft

    S0ft Member HowtoForge Supporter

    Hi, this is only for 1 domain
    but supports www or without www

    / etc/apache2/sites-enabled /
    ls
    there was only one file "000-default"

    vi / etc/apache2/sites-enabled/000-default



    HTML:
    <VirtualHost *:80>
            ServerAdmin [email protected]
    
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
    
            ErrorLog ${APACHE_LOG_DIR}/error.log
    
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
    
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>
    
     
  6. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Are you using nginx or Apache2 in combination with ISPConfig?

    If you're using Apache2 their should be at least one site more (the domain you're actually trying to get SSL running).

    Does the site work if you open it with HTTP protocol instead of HTTPS?
     
  7. S0ft

    S0ft Member HowtoForge Supporter

    thanks for the help michel remote!
    helped me a lot
     

Share This Page