ERROR 101 : wrong username or password / databse empty after update

Discussion in 'Installation/Configuration' started by torusturtle, Jul 20, 2006.

  1. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    ERROR 101 : wrong username or password / database empty after update

    After updateing ISPConfig from 2.2.3 to 2.2.5 I can't login to the ISPConfig Control Panel anymore. Neither as a clilent nor as admin. All I get is the message "ERROR 101 : wrong username or password"

    I checked the mysql database like described in this thread:
    http://www.howtoforge.com/forums/showpost.php?p=9408&postcount=10

    These are the outputs:
    Is there a way to restore the database?
    Unfortunately I didn't backup it this time. :-(
     
    Last edited: Jul 20, 2006
  2. badben

    badben ISPConfig Developer ISPConfig Developer

    There hould be a backup of your sql database created by the upgrade in /tmp I think.
     
  3. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Great!
    There is the file /tmp/existing_db_07_19_2006__14_46_28.sql

    How can I insert this into my existing database?
     
  4. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    I don't know if this was the best way but it worked:

    Everything is back and works again.

    Thanks badben for your hint!
     
  5. vocoder

    vocoder New Member

    Hi.
    I just upgrade from 2.1.0 to 2.2.5
    I have the same problem.
    I search into the /tmp but i did not found any sql db.
    I havent a db backup!!!!
    My ispconfigdb is totaly empty.
    I had 130 clients account and now i have nothing.
    PLEASE help me. Can i found my database anywhere in the server;

    P.S During the upgrading i took the following error:
    Code:
    Connected successfully to db ispconfigdb
    sh: -c: line 0: syntax error near unexpected token `)'
    sh: -c: line 0: `mysqldump -h localhost -u root -p(mypass) -c -t --add-drop-table --add-locks --all --quick --lock-tables ispconfigdb > existing_db.sql'
    cp: cannot stat `existing_db.sql': No such file or directory
    sh: -c: line 0: syntax error near unexpected token `)'
    sh: -c: line 0: `mysql -h localhost -u root -p(mypass) ispconfigdb < db_ispconfig.sql &> /dev/null'
    sh: -c: line 0: syntax error near unexpected token `)'
    sh: -c: line 0: `mysql -f -s -h localhost -u root -p(mypass) ispconfigdb < existing_db.sql &> /dev/null'
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/install_ispconfig/install.php on line 776
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/install_ispconfig/install.php on line 781
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/install_ispconfig/install.php on line 791
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/install_ispconfig/install.php on line 808
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/install_ispconfig/install.php on line 1114
    Restarting some services...
    [Fri Jul 21 01:18:53 2006] [warn] NameVirtualHost (myip):80 has no VirtualHosts
    Shutting down postfix:                                     [  OK  ]
    Starting postfix:                                          [  OK  ]
    Shutting down proftpd:                                     [  OK  ]
    Starting proftpd:  - warning: "ProFTPD" address/port (myip) already in use by "ProFTPD"
                                                               [  OK  ]
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    
    You have mail in /var/spool/mail/root
    [[email protected] install_ispconfig]#
    Please help me.
    Thanks
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Something went wrong with the update. Does your MySQL password contain unusual characters, or is there anything else we should know?
    The SQL dump of the previous database is stored in /tmp, if it isn't there then there's nothing you can do...
     

Share This Page