Error 101 after server restart

Discussion in 'General' started by meat1oaf, Dec 10, 2008.

  1. meat1oaf

    meat1oaf New Member

    Been running ispconfig on Centos 5.1 flawlessly for months now. However, today I had to reboot the server, and when it came back up, i noticed I could not log into the isp control panel at http://myserver:81. All login attempts were countered with the dreaded error 101! System users cannot access the web control panel either.

    Now, all services appear to be running normally. All web sites are still up and running. Email, FTP, and DNS are still functioning properly as far as I can tell.

    I have read thru a few posts regarding generic error 101s, and i can assure you that the database looks fine. I even tried changing my admin password via the mysqli cli. (i noticed that the hash didn't change when I ran the command, so i am remembering my old password correctly.....)

    I am nervous to do anything to risky now since my clients are still up - but wat do you all think I should try next??????????
  2. meat1oaf

    meat1oaf New Member

    Actually, I just noticed that the following appears when you start the ispconfig_server...

    [root@xxxxxxxxx ~]# /etc/init.d/ispconfig_server restart
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    PHP Notice: Undefined variable: HTTP_GET_VARS in /home/admispconfig/ispconfig/lib/ on line 32
    PHP Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/lib/ on line 32
    PHP Notice: Undefined variable: HTTP_POST_VARS in /home/admispconfig/ispconfig/lib/ on line 38
    PHP Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/lib/ on line 38
    PHP Notice: Undefined variable: HTTP_COOKIE_VARS in /home/admispconfig/ispconfig/lib/ on line 44
    PHP Warning: Invalid argument supplied for foreach() in /home/admispconfig/ispconfig/lib/ on line 44
    PHP Notice: Undefined variable: HTTP_GET_VARS in /home/admispconfig/ispconfig/lib/ on line 53

    I had run yum update about two months ago, and php, httpd, and mysql were updated at that time, but all ran well until the reboot.

    Again, any help would be GREATLY appreciated
  3. meat1oaf

    meat1oaf New Member

    Got it!

    The upgrade of PHP must have changed the php.ini.

    I had to set:

    register_long_arrays = On

    in order to avoid those errors. And after restarting ispconfig_server, Voila! I can log in now!

    There is still a small Notice upon server start:

    PHP Notice: Undefined index: s in /home..../ on line 53

    Not sure what that is about....
  4. falko

    falko Super Moderator ISPConfig Developer

    Change the error_reporting to
    error_reporting  =  E_ALL & ~E_NOTICE
    in /root/ispconfig/php/php.ini and restart ISPConfig.
  5. meat1oaf

    meat1oaf New Member

    thanks, but that would only hide the problem... anyone know how to fix the problem?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You changed the error reporting to a value which is not supported by ISPConfig, the solution is to change it back as falko pointed out above.

Share This Page