Erro while upgrading ispconfig

Discussion in 'Installation/Configuration' started by muekno, Feb 23, 2020.

  1. muekno

    muekno Member HowtoForge Supporter

    just tried to update ispconfig on master in multiserver test system
    <code>
    >> Update

    Operating System: Debian 10.0 (Buster) or compatible

    This application will update ISPConfig 3 on your server.

    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:

    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    Checking ISPConfig database .. OK
    PHP Fatal error: Uncaught Error: Call to undefined function mb_detect_encoding() in /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/mysql.lib.php:448
    Stack trace:
    #0 /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/mysql.lib.php(166): db->escape('validate_passwo...')
    #1 /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/mysql.lib.php(231): db->_build_query_string('SELECT plugin_n...', Array)
    #2 /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/mysql.lib.php(270): db->_query('SELECT plugin_n...', Array)
    #3 /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/mysql.lib.php(319): db->query('SELECT plugin_n...', Array)
    #4 /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/update.lib.php(139): db->queryAllRecords('SELECT plugin_n...', Array)
    #5 /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/update.php(315): updateDbAndIni()
    #6 {main}
    thrown in /tmp/update_stable.sh.XrOvPTFU9Z/ispconfig3_install/install/lib/mysql.lib.php on line 448
    </code>
    system was updatet from debian 9 to debian 10 before with no problems, everything seams to run fine
    Rainer
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The error means that you missed installing the php mbstring extension. Take care that you install all PHP modules as described in the Debian 10 perfect setup and in case you installed additional PHP versions from sury.org, then ensure that you switched the default PHP version back to Debian 10's default, which is PHP 7.3.
     
    muekno likes this.

Share This Page