EPSV 500 Command Unknown

Discussion in 'Installation/Configuration' started by Blubmann, Oct 12, 2020.

  1. Blubmann

    Blubmann New Member

    Hello,

    I installed ISPConfig 3 on my Debian Buster. I created a server and activate the pureftpd. Then I create a ftp user and try the connection from internal. Everything work fine. Then I try the connection via ftp. I get the welcome message. I could login in with the ftp commands user and pass. Then I typed in the EPSV command. I need this, because my costumer has a proxy in front of his network. I only get the error 500 Command Unknown. Then I typed in FEAT to see the feature list. I see thet EPSV ist listed, but it does not work.
    I try the same on an Debian Buster which ist manually installed. The EPSV command work. So maybe it is only a wrong setting in ISPConfig.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    It's not clearly stated, but you have an "internal" vs. "external" here, ie. you are using NAT? If so, set pure-ftpd to announce the public ip address, and also setup a passive port range in both pure-ftpd as well as your firewalls/routers.
     
  3. Blubmann

    Blubmann New Member

    Hi,

    I test it again. First from internal EPSV Command not work. Then I test it from external. I created an any to any rule in my firewall and disable all other stuff like ips for the server. I created a portrange in /con-Folder and a external accoucment address. I connect to server via telnet. User and Pass Command work. PASV Command work to, I get the external address. But EPSV through the error Command unknown
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Are you using IPv6? I tested 'EPSV' and I get 'uknown command' on an ipv4 connection (eg. 127.0.0.1), but get a successful response on ipv6 (eg. ::1).
     
  5. Blubmann

    Blubmann New Member

    Hi Jesse,
    I had Ipv4, but I found the reason today. I compare the settings and see that the option BrokenClientsCompatibility was set to yes and this option disable EPSV. I switch it to no and now the EPSV command is recognized. So it is an pureftpd issue.
     
    Jesse Norell likes this.
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Nice find (fwiw, I also have BrokenClientsCompatibility set to yes), that might be worth a bug report to the pure-ftpd project, to not list features when they're unavailable on the current connection.
     

Share This Page