Enhanced Logging With rsyslog - Loggin external hosts

Discussion in 'HOWTO-Related Questions' started by fast Hackem, Dec 13, 2007.

  1. fast Hackem

    fast Hackem New Member

  2. falko

    falko Super Moderator ISPConfig Developer

    I think you must modify /etc/rsyslog.conf, e.g. like this:

    Code:
    *.*       >192.168.0.200,rsyslog,rsyslog_user,rsyslog_user_password
     
  3. fast Hackem

    fast Hackem New Member

    Tried those settings, however I get this message

    db error (2003): Can't connect to MySQL server on '192.168.0.200' (4)

    Does this mean that I need to create table for this host ?
     
  4. fast Hackem

    fast Hackem New Member

    Update: (I thought that I had found the problem)
    I tried to enable logging from remote hosts first, by adding in the -r option
    in /etc/init.d/rsyslog
    RSYSLOGD_OPTIONS="-m 0 -r"

    then Restarted rsyslog

    Still no messages from other hosts.

    So I removed the following
    *.* >192.168.0.200,rsyslog,rsyslog_user,rsyslog_user_password

    still no luck.
     
    Last edited: Dec 16, 2007
  5. fast Hackem

    fast Hackem New Member

    May have solved this one !?

    I skipped this step
    vi /etc/default/rsyslog

    Also had to enter in the -r option here.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Make sure that the client system is allowed to log in to the MySQL server on 192.168.0.200. Also, the MySQL server must use TCP and listen on all interfaces and on port 3306. What's the output of
    Code:
    netstat -tap|grep mysql
    on 192.168.0.200?
     

Share This Page