Enabling quota on NFS-mounted drives

Discussion in 'General' started by catdude, Oct 3, 2007.

  1. catdude

    catdude ISPConfig Developer ISPConfig Developer

    My user directories are all under /its/isp/hosted, which is NFS-mounted from a NAS appliance. I'm now trying to enable quotas on this drive but I'm having no luck. Can anyone direct me to some documentation that shows how to enable quotas over NFS? My attempts with Google and Howtoforge have lead me to pages that don't seem to apply directly.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. catdude

    catdude ISPConfig Developer ISPConfig Developer

    On the ISPConfig machine?
    proc /proc proc defaults 0 0
    /dev/cciss/c0d0p1 / ext3 defaults,errors=remount-ro 0 1
    /dev/cciss/c0d0p9 /home ext3 defaults 0 2
    /dev/cciss/c0d0p8 /tmp ext3 defaults 0 2
    /dev/cciss/c0d0p5 /usr ext3 defaults 0 2
    /dev/cciss/c0d0p6 /var ext3 defaults 0 2
    /dev/cciss/c0d0p7 none swap sw 0 0
    /dev/hda /media/cdrom0 iso9660 ro,user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0 rw,hard,intr,usrquota,rsize=16384,wsize=16384 0 0
    192.168.200.52:/webhost/hosts /its/isp/hosted nfs rw,hard,intr,rsize=16384,wsize=16384 0 0

    On the NFS server (NAS appliance)? Not sure. I've e-mailed the engineer that runs that device and asked him.
     
  4. mlz

    mlz New Member

    Might want to turn usrquota on...
     
  5. catdude

    catdude ISPConfig Developer ISPConfig Developer

    That has to be done on the NFS server, right? When I try to add usrquota to the options in fstab on the ISPConfig server I get error messages. The engineer running the NAS box I'm NFS-mounting from tells me that usrquota is turned on at the NAS box, but I'm waiting for him to verify that for me.
     
  6. mlz

    mlz New Member

    If I remember correctly, it must be done on the mounting machine, and the quota files created on the master.
     
  7. catdude

    catdude ISPConfig Developer ISPConfig Developer

    If it has to be done on the mouting machine, then I'm not finding the correct syntax. I've tried using a line like:
    192.168.200.52:/webhost/hosts /its/isp/hosted nfs rw,hard,intr,usrquota,rsize=16384,wsize=16384 0 0

    but "mount" complains that "usrquota" is an unrecognized option and dies. I've also tried "quota" and "quotas" (found from other Google results) with the same result.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    192.168.200.52:/webhost/hosts /its/isp/hosted nfs rw,hard,intr,usrquota,rsize=16384,wsize=16384,usrquota,grpquota 0 0
    Make sure that the quota package is installed and that you configure quota on /its/isp/hosted as shown at the end of http://www.howtoforge.com/perfect_setup_debian_etch_p3 .
     

Share This Page