Enabling Multiviews

Discussion in 'Installation/Configuration' started by vincentthe, Dec 22, 2006.

  1. vincentthe

    vincentthe New Member


    I'm having difficulties getting Multiviews to work. If I look in the config files, it seems to be present, however : www.domain.ext/index/0 won't work as it should (index.php 0 as the first path variable).

    Is there a way to enable multiviews by default for all sites? If not, what is the quickest way to get it to work for individual sites?

    I tried adding stuff like:
    <Directory "/var/www/*"> (or the specific dir)
    Options All Multiviews
    to the Optional Apache Directives field.

    .htaccess doens't help me either: Adding anything resembling "Options (+)Multivies" gives a 500 Internal server error
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    At the end of your apache2.conf file, you will find a definition like this:

    <Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all

    <Files ~ "^\.ht">
    Deny from all

    Change the line:

    Options +Includes +FollowSymlinks -Indexes


    Options +Includes +FollowSymlinks -Indexes +Multiviews

    and restart the apache server.
  3. vincentthe

    vincentthe New Member

    Thanks for the quick reply, works like a charm :)

Share This Page