enabling https:// for specific domains

Discussion in 'Installation/Configuration' started by dynamind, Feb 20, 2012.

  1. dynamind

    dynamind Member

    Since october 11 facebook requires a secured connection for fanpages, so I tried to enable https for a domain but apache2 failed to start.
    I entered all data in the SSL Panel except SSL Request, SSL Certifikat& SSL Bundle.
    Then I changed SSL Action to "Save Certificate". After that apache2 crashed, I wasn't able to restart the webserver.

    Is ISPconfig3 able to create the SSL keys or do I have to pre-create the keys with openssl? What's the correct/best way to enable SSL for domains?
     
    Last edited: Feb 20, 2012
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes.

    No.

    Select a IP address in the website settings and enable the ssl checkbox, then enter the details of the ssl cert on the ssl tab of the website. make sure that you dont enter any special chars as this can cause openssl to fail to create the correct certs. Then choose create certificate as action and click on save.

    This is described in detail in the manual.
     
  3. dynamind

    dynamind Member

    I bought your manual

    thanks, I see & I guess the wildcard was my fault.
    updated: works!
    till, you're my webhosting-panel-god ; )
     
    Last edited: Feb 20, 2012
  4. kwickcut

    kwickcut Member

    i have tried this but when i type in the url for the site i want to use the ssl cert on i am directed to the main server page..

    Code:
    http://server.com is the same as https://mysite.com
    how do i get around this
     
  5. dynamind

    dynamind Member

    Last edited: Feb 26, 2012

Share This Page