enable php cli for jailkit chrooted user

Discussion in 'Installation/Configuration' started by ftassi, May 2, 2010.

  1. ftassi

    ftassi ISPConfig Developer ISPConfig Developer

    hi all,

    i'm trying to configure ispconfig to have ssh user that can use php-cli. My ultimate goal is to create with ispconfig a jailkit user that can run symfony task.

    I've tryed to changing jailkit conf in ispconfig setting :

    /usr/bin/php in " Jailkit chrooted applications" field but it didn't work.

    perhaps this is a jailkit configuration issue rather than an ispconfig one, but i really don't get it and i'm not able to find any usefull information over the web

    thanks for your help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you ctreated a new website after you added /usr/bin/php to the jailed applications? The jail gets only created once when a website get created, it does not get created when you e.g. add a ssh user to a website that has alraedy jailed ssh users.

    To debug this, please create a new website for testing, then add a new jailed ssh user to this site and then check if /usr/bin/php is present in the jail.

    Also, is /usr/bin/php the real cli php binary or just a symlink to the binary. You can e.g. test this with:

    ls -la /usr/bin/php

    If its a symlink, find the php-cli binary and add the path to it in the jailkit configuration instead.
  3. ftassi

    ftassi ISPConfig Developer ISPConfig Developer

    No, I haven't created a new website, only a new user.

    In my env(ubuntu) /usr/bin/php is a symlink to a file that is a symlink to another file, the real path for the php-cli is


    so i've used this one in the jailkit confìguration parameter.

    After changing the conf i've created a new site and a new ssh user for it but it still can't use php.

    Did you have any other idea ?
    Have to wait time between changing jailkit conf and create new site (maybe some cronjob need to run before create a new site with the new conf ?)

    Thank for the replay.

Share This Page