Enable logging for customer

Discussion in 'General' started by pinkfeet, Jul 28, 2014.

  1. pinkfeet

    pinkfeet New Member HowtoForge Supporter

    Hi,

    Are there way to enable logs for custmer inside his path (/var/www/customer/web) ? Or /var/www/customer/log ?

    Sometimes, any customer wants to see his logs if he is programming or something like that. I like admin can see logs in /var/log/ispconfig/customer/logs but customer can't see it.

    How could I do that?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The logs are always available for the customer in his log directory. The log directors is e.g. /var/www/domain.tld/log when the customer owns the website domain.tld
     
  3. pinkfeet

    pinkfeet New Member HowtoForge Supporter

    Hi

    Thanks you for reply, but I have that path empty, i haven't logs in that directory, however I can see logs in /var/log/ispconfig/httpd/domain/

    [email protected]:/var/log/ispconfig/httpd/domain.com# ls -alh
    total 12M
    drwxr-xr-x 2 root root 4.0K Jul 28 13:26 ./
    drwxr-xr-x 9 root root 4.0K Jul 28 10:56 ../
    -rw-r--r-- 1 root root 68K Jul 28 13:26 20140728-access.log
    lrwxrwxrwx 1 root root 19 Jul 28 13:26 access.log -> 20140728-access.log
    -rw-r--r-- 1 root root 1.2M Jul 28 12:44 error.log

    [email protected]:/var/www/domain.com/log# ls -alh
    total 8.0K
    drwxr-xr-x 2 root root 4.0K Jun 30 12:59 ./
    drwxr-xr-x 10 root root 4.0K Jul 1 00:30 ../

    Should I change any options in my ispconfig?
    Thanks again
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No

    Seems as if the bind mount are not working on your server. You should have a bind mount line for each log directory in /etc/fstab that binds the directory /var/www/domain.com/log to /var/log/ispconfig/httpd/domain.com
     
  5. pinkfeet

    pinkfeet New Member HowtoForge Supporter

    Great, I had lines in my /etc/fstab but my command mount hadn't that lines enabled. I needed some packages for quotas too as: e2fsprogs & chattr (I dont know if its the cause or not). After I installed that packages and re-mount the partitions, now I can see logs under customer's path.

    So, we can mark this ticket as "solved".

    Thanks you for your time & work Till.
     

Share This Page