Enable http2 on Debian 9 with Apache 2.4.25 & ISPConfig

Discussion in 'Installation/Configuration' started by Christoph80, Sep 5, 2019.

  1. Christoph80

    Christoph80 New Member

    OK - Sorry - but it's like becoming crazy: I can't disable "mpm_prefork"
    If I disable the module, Apache2 do not (re-)start.
    Even If I enable "mpm_event" the "Apache" do not come up.
    The final message is still:
    Website works without problems, but there's still nothing served by http2
     
  2. nhybgtvfr

    nhybgtvfr Active Member

    a2dismod php*
    a2dismod mpm_prefork
    a2enmod php*-fpm
    a2enmod mpm_event

    if you still get the message about php not being threadsafe, try:
    apt-get remove libapache2-mod-php*
     
  3. Christoph80

    Christoph80 New Member

    After this steps it seems to be that my Apache is totaly demaged :-(

    STOP WAIT.... Thank You Thank You.... Now everything seems to be fine! There was just a sytax-error in the vhost of a domain... But now it works
     
    Last edited: Sep 6, 2019
  4. Steini86

    Steini86 Active Member

    There is still mod_php activated for this domain. The "php_admin_value" command cannot be used without mod_php, thats why there is this error. If you deactivate mod_php Apache will not start up. You first have to change all domains to php_fpm, then deactivate mod_php, then restart apache.

    [edit]
    Good to hear it works now!
     
  5. Christoph80

    Christoph80 New Member

    Thanx a lot for your help (Steine69, Till and nhybgtvfr)...

    There are still two resulting problems/issues - maybe you can help again.
    1. After the switch from "mod_php" to "php-fpm" - "phpmyadmin" do not work (browser show plain php-code). I think it's because php is not parsed. How to change phpyadmin to "php-fpm" ... It's located on 111.111.111.111:8080/phpmyadmin
    2. After switch to "php-fpm" my websites start with an internal sever error (500) because I've some rules in the .htaccess files (php_value error_reporting 7, php_flag display_errors On, php_value memory_limit 4096M, php_value max_execution_time 180, ...). I fixed the problem with a # on each line). But the question is: How can I turn on display_errors again. In which file I can setup the global values for max_execution_time, php_memory_limit etc. pp.
     
  6. Steini86

    Steini86 Active Member

    Regarding problem 2:
    You should be able to use "SetEnv PHP_VALUE" instead. The better way would be to add this to your PHP config where it belongs (last tab in website options of ispconfig) options -> Custom php.ini settings
    and so on..
     
  7. Christoph80

    Christoph80 New Member

    Works like a charm, thank you...

    Now I just have to fix the problem with "phpmadymin"
     
  8. Steini86

    Steini86 Active Member

Share This Page