Enable directory listing on ISPConfig (nginx)

Discussion in 'General' started by [email protected] Rasta, May 2, 2013.

  1. Hi. Help me to enable directory listing, please.

    My configuration:
    Ubuntu 13.04
    ISPConfig 3.0.5.2
    Nginx 1.2.6

    I've added a web site to ISPConfig, uploaded folder with file and added nginx directive, but no luck... Getting error "403 Forbidden"
     

    Attached Files:

    Last edited: May 2, 2013
  2. I will be grateful for any help...
     
  3. I don't know what was wrong, but it's working now! :eek:
    Must be that I added subdir to directive, not just var/www/mywebsite/web but var/www/mywebsite/web/folder
     
    Last edited: May 6, 2013
  4. And it's not working again after resaving site options. I can't get it :mad:
     
  5. GOT IT!!!
    To use autoindex, you should add a custom dir, root dir (./web) will not be accessable. So in the end of configuration you should open
    Code:
    http://yoursite/customdir/

    Settings below...

    nginx Directives
    Code:
    location / {
    	autoindex on;
    }
     

    Attached Files:

    Last edited: May 6, 2013

Share This Page