Empty Recycle Bin

Discussion in 'General' started by jon335, Oct 7, 2005.

  1. nenad

    nenad ISPConfig Developer ISPConfig Developer

    There is still segmentation fault error:

    [root@web-hosting-solutions compile_php_5_0_4]# /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    start
    Segmentation fault
    You have new mail in /var/spool/mail/root
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    /root/ispconfig/php/php -v
    ?
     
  3. nenad

    nenad ISPConfig Developer ISPConfig Developer

    [root@web-hosting-solutions ~]# /root/ispconfig/php/php -v
    PHP 5.0.4 (cli) (built: Apr 19 2006 10:00:32)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please run:

    strace /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    and post the trace output.
     
  5. nenad

    nenad ISPConfig Developer ISPConfig Developer

    Complete output?

    It looks like this script generates some kind of loop...

    The output is quite BIG , I don't know how to catch it and post it...

    Script holds for a while at some point , then countinue and final output is:

    mremap(0xb7bb7000, 139264, 274432, MREMAP_MAYMOVE) = 0xb7b4a000
    brk(0x98ae000) = 0x98ae000
    brk(0x98cf000) = 0x98cf000
    brk(0x98f0000) = 0x98f0000
    brk(0x9911000) = 0x9911000
    brk(0x9932000) = 0x9932000
    brk(0x9953000) = 0x9953000
    brk(0x9974000) = 0x9974000
    brk(0x9995000) = 0x9995000
    mremap(0xb7d39000, 139264, 278528, MREMAP_MAYMOVE) = 0xb7b06000
    brk(0x99b6000) = 0x99b6000
    brk(0x99d7000) = 0x99d7000
    brk(0x99f8000) = 0x99f8000
    brk(0x9a19000) = 0x9a19000
    brk(0x9a3a000) = 0x9a3a000
    brk(0x9a5b000) = 0x9a5b000
    brk(0x9a7c000) = 0x9a7c000
    brk(0x9a9d000) = 0x9a9d000
    brk(0x9abe000) = 0x9abe000
    --- SIGSEGV (Segmentation fault) @ 0 (0) ---
    +++ killed by SIGSEGV +++
    Process 11729 detached
    [root@web-hosting-solutions ~]#
     
  6. nenad

    nenad ISPConfig Developer ISPConfig Developer

    How to manually DELETE those entries from Recycle Bin?

    Now I have problems even with adding A records for mail:

    Althought there is:
    IP-Adresse Hostname
    87.116.136.92 www
    87.116.136.92 mail
    87.116.136.92 ns1
    87.116.136.92 ns2

    It seems that it is not writen in dns conf or zome or what ever files.
    http://www.dnsstuff.com/tools/lookup.ch?name=web-hosting-solutions.biz&type=A

    Doesn't show my mail.web-hosting-solutions.biz

    And it was working good until today.
    Reboot (delete from A records and write back again) and everything elese (including webmin) don't help.

    What should I do, which file should I manually edit to resolve this error:

    mail.web-hosting-solutions.biz: Could not connect without glue or A record.

    and this one

    ERROR: None of your mail server(s) seem to have reverse DNS (PTR) entries (I didn't get any responses for them).

    http://www.dnsreport.com/tools/dnsreport.ch?domain=www.web-hosting-solutions.biz

    P.S. IMHO RecycleBin create lots of problemes. Is ther possibility do DISABLE it?
     
    Last edited: Apr 21, 2006
  7. nenad

    nenad ISPConfig Developer ISPConfig Developer

    Finally I done it using brute force.
    In PHPAdmin I found every single DNS record for items that remained in RecycleBin , and I deleted them.

    And it was effective.
    ISPConfig as well as other sites are still fully operational.

    But, there is another issue.
    I hosted website neoplanta.com and few days ago I deleted it.

    But I see that tehre is lot of entires remained in Database (I removed them), and complete website structure remained???
    Allthogether with symlinks in /var/www ??

    I tought that all of that has to be deleted when I delete site in ISPConfig ?
     
  8. nenad

    nenad ISPConfig Developer ISPConfig Developer

    This error existed BEFORE I edited manually anything in database with PhpAdmin:

    Problems with indexes of table `del_status`
    Warning PRIMARY and INDEX keys should not both be set for column `id`
    Problems with indexes of table `dns_nodes`
    Warning PRIMARY and INDEX keys should not both be set for column `tree_id`
    Problems with indexes of table `doctype`
    Warning PRIMARY and INDEX keys should not both be set for column `doctype_id`
    Problems with indexes of table `groups`
    Warning PRIMARY and INDEX keys should not both be set for column `groupid`
    Problems with indexes of table `help_documents`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `help_nodes`
    Warning PRIMARY and INDEX keys should not both be set for column `tree_id`
    Problems with indexes of table `isp_dep`
    Warning PRIMARY and INDEX keys should not both be set for column `dep_id`
    Problems with indexes of table `isp_fakt_dep`
    Warning PRIMARY and INDEX keys should not both be set for column `dep_id`
    Problems with indexes of table `isp_fakt_nodes`
    Warning PRIMARY and INDEX keys should not both be set for column `tree_id`
    Problems with indexes of table `isp_htaccess`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `isp_nodes`
    Warning PRIMARY and INDEX keys should not both be set for column `tree_id`
    Problems with indexes of table `isp_server_ip`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `isp_traffic`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `listtype`
    Warning PRIMARY and INDEX keys should not both be set for column `listtype_id`
    Problems with indexes of table `login`
    Warning PRIMARY and INDEX keys should not both be set for column `login_id`
    Problems with indexes of table `multidoc_dep`
    Warning PRIMARY and INDEX keys should not both be set for column `dep_id`
    Problems with indexes of table `multidoc_nodes`
    Warning PRIMARY and INDEX keys should not both be set for column `tree_id`
    Problems with indexes of table `session`
    Warning PRIMARY and INDEX keys should not both be set for column `id`
    Problems with indexes of table `sys_dep`
    Warning PRIMARY and INDEX keys should not both be set for column `dep_id`
    Problems with indexes of table `sys_modules`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `sys_news`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `sys_nodes`
    Warning PRIMARY and INDEX keys should not both be set for column `tree_id`
    Problems with indexes of table `sys_user`
    Warning PRIMARY and INDEX keys should not both be set for column `doc_id`
    Problems with indexes of table `user_groups`
    Warning PRIMARY and INDEX keys should not both be set for column `usergroupid`
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No. If you delete records manually in the datbase, you will mess up your system. ISPConfig is a complex system and has dependency tables isp_nodes, isp_dep and dns_nodes, dns_dep. If these are not in sync with the other tables, your system will fail sooner or later.
     
  10. nenad

    nenad ISPConfig Developer ISPConfig Developer

    OK.

    What about ISPConfig is not deleting the deleted webistes data in /var/www ?

    Why is that happening?
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    If it doesn't delete the web sites in /var/www, then something is wrong with your installation. IT is likely that this has something to do with you deleting records manually in the database.
     
  12. nenad

    nenad ISPConfig Developer ISPConfig Developer

    No, folders and files were not deleted long time before I manually deleted data for recycle bin / nonexisting DNS records
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    But creating new records like email addresses and domains worked?

    I guess that the complete server part is not working on your server.
     
  14. nenad

    nenad ISPConfig Developer ISPConfig Developer

    Yes, it worked.

    Recycle bin is still not working normaly.
    If I create user and then delete it, user can't be removed from recycle bin.

    In case that I want to re-install ISPConfig, do I need to re-install complete OS?
     
  15. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That would be the safest way...
     
  16. nenad

    nenad ISPConfig Developer ISPConfig Developer

    Done.

    I reinstalled OS and fresh installed ISPConfig 2.2.1
    (last time it was upgrade from 2.2.0 --> 2.2.1)

    -----------------------------------------------------

    Update: untill now there is mo problems with recycle bin.

    System is clean 100%.
    I even didn't installed webmin or updated system using yum update all

    I created few websites and users and later deleted them.
    No problems at all.
    Recycle bin is empty. Files and directories are deleted too.
     
    Last edited: Apr 23, 2006
  17. nenad

    nenad ISPConfig Developer ISPConfig Developer

    This:
    strace /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    does not produces any errors any more and executes very fast.

    This gives that:
    [root@server1 www]# /root/ispconfig/php/php -v
    PHP 5.1.2 (cli) (built: Apr 22 2006 21:24:15)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    P.S. I noticed in past few days lots of errors created by MySQL.
    Output was on servers terminal.
    How to log / redirect output of mysql errors somewhere else instead to term?
    If that happed again...

    I re-installed OS and ISPConfig.

    This time I set up UTF-8 as the default character encoding for the whole server
    In /etc/mysql/my.cnf
    In section [mysqld]
    I added:
    default-character-set=utf8

    immediatelly after re-installing of OS, before installing ISPConfig.

    Instead of default latin-swedish , just in case...
     
    Last edited: May 2, 2006
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    There are some logging directives in the mysql my.cnf configuration file.

    You can find it with: locate my.cnf
     
  19. nenad

    nenad ISPConfig Developer ISPConfig Developer

    This is what happened on new installation.

    There was user web3_nenad (web-hosting-solutions.biz)
    I could read emails, ftp etc.

    But usewr somehow dissapeard from ISPConfig?

    I deleted complete website from ISPConfig, empty recycle bin, and the tried to add again same website, but system is informing me that I can't do that because website allready exists?

    Search didn't helped.
    Threre's no segfault error.

    ???
     
  20. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What exactly did you do? A user cannot simply disappear from ISPConfig. Did yoi maybe do some manual changes in the ISPConfig database?
     

Share This Page