empty maildir /tmp after quota problem clamav

Discussion in 'General' started by Jorem, Jun 18, 2008.

  1. Jorem

    Jorem New Member

    I had the clamav quota problem with the mailusers. I solved this with the switch to clamd. But the mail users are still near to there max on quota.

    When I delete an account and make a new one everything works fine and quota stays normal. Is there a way how to clean the Maildir of a user without having to delete and create the account again.

    The clamav problem had something to do with the tmp files. Can they be cleaned with a command for example? I tried a reboot but that did not work for the users.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont think that the files are in the maildir. When you recreate the user, he gets a new userid, thats why the quota is normal then. But the original files are most likely still on your harddisk. Do you have any directories starting wih "clamav" in /tmp ? If yes, delete them.

    Do you have mbox files with a size > 0 in /var/spool/mail/ ?
  3. Jorem

    Jorem New Member

    Do you have any directories starting wih "clamav" in /tmp ? If yes, delete them?
    Yes, I deleted them but this did not help.

    Do you have mbox files with a size > 0 in /var/spool/mail/ ?


    I only have this problem with the account that had antivirus on. Now I have turned it off, but the quota keeps telling me that there account is full.
    When I check the Maildir of the user ( /home/www/web13/user/hugo ) I see that there are no mails in new, cur and the other folders.
    But when I do a quota check in Webmin it sais that the user used 16MB of space.
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    repquota -avug
  5. Jorem

    Jorem New Member

    This is a part of the quota check:

    web84 -- 1840 51200 52224 175 0 0
    web89 -- 141528 307200 308224 1649 0 0
    web39 -- 12376 51200 52224 423 0 0
    web83 -- 1672 5120 6144 174 0 0
    web3 -- 203836 1024000 1025024 16173 0 0
    web140 -- 20708 102400 103424 338 0 0
    web22 -- 586348 1024000 1025024 6230 0 0
    web104 -- 10908 102400 103424 158 0 0
    web66 -- 156216 256000 257024 12273 0 0
    web17 -- 338976 2560000 2561024 11553 0 0
    web82 -- 12600 102400 103424 591 0 0

    I updated all the users already and set the quota 10MB higher. web66 for example has 15MB, but when I go to the user folders I don't see any files there.
  6. falko

    falko Super Moderator ISPConfig Developer

    web66 is a group which means that all users that belong to that group have used 15MB of space.

Share This Page