emails stopped, ispconfig no login w mysql error

Discussion in 'General' started by Turbanator, Feb 2, 2009.

  1. Turbanator

    Turbanator HowtoForge Supporter

    ok this was posted on another thread but I want to put it here so that the title shows the severity...sorry about that.

    I try to login to the ispconfig admin page and get the following after login;
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 62



    I only noticed because a clinet said they cannot send email.
    So I tested and so far I cannot RECIEVE or SEND email through the server, and I'm assuming it's all tied to th above problem.

    I'm running fedora 9 x86_64 and I think I did the latest yum updates this past weekend, but didn't get a report of problems until this morning.

    I even went into mysql and RE-granted root access and flush priv. but that didn't help.

    This is major with the emails down, please help.

    BTW, websites are running fine with mysql.

    TIA
     
  2. Turbanator

    Turbanator HowtoForge Supporter

    neverind, it's fixed.

    ok not sure how or why this happened but it's fixed.

    1st this is to doubcheck that your mysql password for ispconfig is correct.
    /home/admispconfig/ispconfig/lib/config.inc.php

    If it's correct (or not), I suggest then going to mysql and setting the grants and authorize again.

    Next, reinstall ispconfig. I'm the latest release and did a reinstall over the existing and everything worked perectly.
     

Share This Page