Emails not working [URGENT]

Discussion in 'General' started by AusHell, Jun 24, 2008.

  1. AusHell

    AusHell New Member

    Hey guys,


    I am having huge problems with getting the emails on the server working.. i followed the "pefect install" for cent os 5.1

    i have added the account to outlook, i can email send an email from that account through outlook and it will send.. but i cant recieve anything.. its almost like the mailbox isn't working :S

    I have read through many posts and still have no idea what is causing the problem..

    I have also been looking through logs.. i thought it could be a DNS issue.. but it cant be, as i have solved the hostname and domain name issues...

    Here a snippet from the /var/log/maillog

    PLEASE NOTE: XXX.XXX.XXX.XXX my servers ip. (i have masked it purposely)


    Code:
    Jun 24 15:19:50 assasrv02 postfix/tlsmgr[5830]: warning: cannot open entropy device /dev/urandomhome_mailbox = Maildir/: No such file or directory
    Jun 24 15:19:50 assasrv02 postfix/tlsmgr[5830]: exiting to reopen external entropy source dev:/dev/urandomhome_mailbox = Maildir/
    Jun 24 15:19:51 assasrv02 postfix/tlsmgr[5831]: warning: cannot open entropy device /dev/urandomhome_mailbox = Maildir/: No such file or directory
    Jun 24 15:19:51 assasrv02 postfix/tlsmgr[5831]: exiting to reopen external entropy source dev:/dev/urandomhome_mailbox = Maildir/
    Jun 24 15:19:52 assasrv02 postfix/tlsmgr[5832]: warning: cannot open entropy device /dev/urandomhome_mailbox = Maildir/: No such file or directory
    Jun 24 15:19:52 assasrv02 postfix/tlsmgr[5832]: exiting to reopen external entropy source dev:/dev/urandomhome_mailbox = Maildir/
    Jun 24 15:19:53 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:XXX.XXX.XXX.XXX, lip=::ffff:XXX.XXX.XXX.XXX
    Jun 24 15:19:53 assasrv02 postfix/tlsmgr[5835]: warning: cannot open entropy device /dev/urandomhome_mailbox = Maildir/: No such file or directory
    Jun 24 15:19:53 assasrv02 postfix/tlsmgr[5835]: exiting to reopen external entropy source dev:/dev/urandomhome_mailbox = Maildir/
    Jun 24 15:19:53 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    

    Please let me know what you think the problem is?..
     
    Last edited: Jun 24, 2008
  2. Ben

    Ben New Member Moderator HowtoForge Supporter ISPConfig Developer

    Please post the content of /etc/postfix/main.cf, but please without comments (lines starting with #).

    In my conf I got the following line:
    In your case this should look similar to the following and maybe causing the error:
    Maybe its also mixed up with the followign line that in my main.cf contains the home_mailbox containing "Maildir/" that is also mentioned in your errormessage, so maybe just a newline is missing?

     
  3. AusHell

    AusHell New Member

    This is the main.cf file

    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = $myhostname, assasrv02.$mydomain, localhost
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
             PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
             xxgdb $daemon_directory/$process_name $process_id & sleep 5
    
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    smtpd_sasl_local_domain = safetynetwork.net.au
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandomhome_mailbox = Maildir/
    mailbox_command = 
    
     
  4. Snowman

    Snowman Member

    In your config at line ---> tls_random_source = dev:/dev/urandomhome_mailbox = Maildir/

    thats the problem : there are 2 lines in one try to split it :
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/

    hm?
     
  5. Ben

    Ben New Member Moderator HowtoForge Supporter ISPConfig Developer

    As I already suggested ;)
     
  6. Snowman

    Snowman Member

    yop ! but no answer from author :)
     
  7. AusHell

    AusHell New Member

    Sorry for the delayed reply i have been busy.

    That fixed a part of the error but i am still getting a reply email error saying this.

    Code:
    <test@protectyourkids.net>:
    203.201.149.70 does not like recipient.
    Remote host said: 554 5.7.1 <test@protectyourkids.net>: Relay access denied Giving up on 203.201.149.70.
    We can send out from problem server but cannot receive. When we send from a working account to an email on this new server we get error 554 relay access denied.
     
    Last edited: Jul 2, 2008
  8. AusHell

    AusHell New Member

    This is the latest paste of the mailog file..

    /var/log/mailog


    Code:
    Jul  2 11:12:06 assasrv02 postfix/postfix-script: starting the Postfix mail system
    Jul  2 11:12:06 assasrv02 postfix/master[19970]: daemon started -- version 2.3.3, configuration /etc/postfix
    Jul  2 11:12:13 assasrv02 postfix/smtpd[19976]: connect from warp.ecn.net.au[203.22.70.2]
    Jul  2 11:12:13 assasrv02 postfix/smtpd[19976]: NOQUEUE: reject: RCPT from warp.ecn.net.au[203.22.70.2]: 554 5.7.1 <test@protectyourkids.net>: Relay access denied; from=<daniel@assaohs.com.au> to=<test@protectyourkids.net> proto=SMTP helo=<warp.ecn.net.au>
    Jul  2 11:12:13 assasrv02 postfix/smtpd[19976]: disconnect from warp.ecn.net.au[203.22.70.2]
    Jul  2 11:12:13 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:13 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:13 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:13 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:14 assasrv02 dovecot: pop3-login: Login: user=<web6_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:14 assasrv02 dovecot: POP3(web6_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:14 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:14 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:14 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:15 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:15 assasrv02 dovecot: pop3-login: Login: user=<web6_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:15 assasrv02 dovecot: POP3(web6_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:15 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:15 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:15 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:16 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:16 assasrv02 dovecot: pop3-login: Login: user=<web6_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:16 assasrv02 dovecot: POP3(web6_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:16 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:16 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:16 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:16 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:12:16 assasrv02 dovecot: pop3-login: Login: user=<web6_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:12:16 assasrv02 dovecot: POP3(web6_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:13:17 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:13:17 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:13:17 assasrv02 dovecot: pop3-login: Login: user=<web5_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:13:17 assasrv02 dovecot: POP3(web5_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jul  2 11:13:17 assasrv02 dovecot: pop3-login: Login: user=<web6_test>, method=PLAIN, rip=::ffff:203.201.138.68, lip=::ffff:203.201.149.70
    Jul  2 11:13:17 assasrv02 dovecot: POP3(web6_test): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    
     
  9. AusHell

    AusHell New Member

    Ok guys, Thanks for the help along the way..

    I have finally fixed the problem.


    this line was not in the main.cf file.

    myhostname = server1.example.com

    as soon as i added it and changed it to my server and domain details it worked ..


    Receiving emails fine ;)
     

Share This Page