Emails not going where they are meant to

Discussion in 'General' started by slighty_sykotic, Aug 3, 2006.

  1. slighty_sykotic

    slighty_sykotic New Member

    Hi,

    First off, thanks for ispconfig

    Now, i've tired to search, but can't get get what the problem is.

    Running ispconfig on debian by using the perfect install setup guide. Most things are working great, but im confused with email...

    Sending is no problem at all.

    Receiving is the problem...
    When I send a email from a external account it doesnt appear in the user's mail box, and this is what the log looks like:


    Aug 2 14:09:04 rocket postfix/smtpd[15909]: connect from fep05.xtra.co.nz[210.54.141.241]
    Aug 2 14:09:04 rocket postfix/smtpd[15909]: 95F1617C16F: client=fep05.xtra.co.nz[210.54.141.241]
    Aug 2 14:09:04 rocket postfix/cleanup[15912]: 95F1617C16F: message-id=<[email protected]>
    Aug 2 14:09:04 rocket postfix/qmgr[2323]: 95F1617C16F: from=<[email protected]>, size=1584, nrcpt=1 (queue active)
    Aug 2 14:09:04 rocket postfix/smtpd[15909]: disconnect from fep05.xtra.co.nz[210.54.141.241]
    Aug 2 14:09:04 rocket postfix/pickup[14242]: C39D917C170: uid=10002 from=<web1_jetpack>
    Aug 2 14:09:04 rocket postfix/cleanup[15912]: C39D917C170: message-id=<[email protected]>
    Aug 2 14:09:04 rocket postfix/local[15914]: 95F1617C16F: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Aug 2 14:09:04 rocket postfix/qmgr[2323]: 95F1617C16F: removed
    Aug 2 14:09:04 rocket postfix/qmgr[2323]: C39D917C170: from=<[email protected]>, size=351, nrcpt=1 (queue active)
    Aug 2 14:09:04 rocket postfix/local[15914]: C39D917C170: to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Aug 2 14:09:04 rocket postfix/qmgr[2323]: C39D917C170: removed

    From [email protected] to [email protected]


    Domain name settings on my domain are as follows:

    Host Name IP Address
    jetpack.co.nz Points To 203.114.130.59
    ns2.jetpack.co.nz Points To 203.114.130.59
    ns1.jetpack.co.nz Points To 203.114.130.59
    www.jetpack.co.nz Points To 203.114.130.59
    mail.jetpack.co.nz Points To 203.114.130.59

    --------------------------------------------------------------------------------

    Alias ("CName" Record)
    No Alias records were defined
    --------------------------------------------------------------------------------

    Mail Servers ("MX" Record)
    Host Name Priority Mail Server
    mail.jetpack.co.nz X-Hi mail.jetpack.co.nz



    (this is on a external name server, Thats the second thing I havn't got running yet... The name server... Will get to that after the email )


    Oh yeah, using Postfix and Maildir is ENABLED.

    Thanks alot,

    Bradley.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which pop3 / smtp server do you use? courier?
     
  3. slighty_sykotic

    slighty_sykotic New Member

    Yes, that was the one in the perfect guide I believe. But I now can't find any trace of it... Im still looking for it on the server.

    Where is it meant to be installed to?

    Thanks.
     
  4. slighty_sykotic

    slighty_sykotic New Member

    Hmm, ok, I can't find it at all, so im reinstalling it now.... I guess that I may have missed this...
     
  5. slighty_sykotic

    slighty_sykotic New Member

    Ok, it works now :)

    One question though,

    Then configure Postfix to deliver emails to a user's Maildir*:

    postconf -e 'home_mailbox = Maildir/'
    postconf -e 'mailbox_command ='
    /etc/init.d/postfix restart

    *Please note: You do not have to do this if you intend to use ISPConfig on your system as ISPConfig does the necessary configuration using procmail recipes. But please go sure to enable Maildir under Management -> Settings -> EMail in the ISPConfig web interface.

    I did the part that I apparently didnt have to.... Does this matter?


    And another thing, can I make the email and/or the admin ispconfig regular http, instead of https? ( I know you can do it during install, but can you change it on a running server).


    Thanks again
     
  6. falko

    falko Super Moderator ISPConfig Developer

    No, that's fine.


    Have a look here: http://www.howtoforge.com/forums/showthread.php?t=3732&highlight=https http ispconfig
     

Share This Page