emails not delivering from roundcube configured from ispconfig

Discussion in 'Installation/Configuration' started by vinodbathi, May 31, 2021.

  1. vinodbathi

    vinodbathi New Member HowtoForge Supporter

    Hi,

    Created single ispconfig server with web, DB, DNS, mail all in a single server.
    Added a client and Domain, created an email account, and to that mail, emails are receiving from external Domain but unable to send any mail from that domain to external domain.
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  3. vinodbathi

    vinodbathi New Member HowtoForge Supporter

    Here is the mail.log content

    Code:
    Jun  1 21:58:17 cp postfix/smtpd[4873]: connect from localhost[127.0.0.1]
    Jun  1 21:58:17 cp postfix/smtpd[4873]: 5FDBD41C9C: client=localhost[127.0.0.1]
    Jun  1 21:58:17 cp postfix/cleanup[4858]: 5FDBD41C9C: message-id=<[email protected]>
    Jun  1 21:58:17 cp postfix/smtpd[4873]: disconnect from localhost[127.0.0.1] ehlo=1 mail=1 rcpt=2 data=1 quit=1 commands=6
    Jun  1 21:58:17 cp postfix/qmgr[1763]: 5FDBD41C9C: from=<[email protected]>, size=16169, nrcpt=2 (queue active)
    Jun  1 21:58:17 cp amavis[2274]: (02274-02) Passed CLEAN {RelayedOutbound}, ORIGINATING LOCAL [127.0.0.1] <[email protected]> -> <[email protected]>,<[email protected]>, Message-ID: <[email protected]>, mail_id: V98Oi0SXMC7W, Hits: -0.989, size: 15774, queued_as: 5FDBD41C9C, 3011 ms
    Jun  1 21:58:17 cp postfix/lmtp[4861]: 514CA3FF93: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=3.1, delays=0.07/0.01/0/3, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10027): 250 2.0.0 Ok: queued as 5FDBD41C9C)
    Jun  1 21:58:17 cp postfix/lmtp[4861]: 514CA3FF93: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=3.1, delays=0.07/0.01/0/3, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10027): 250 2.0.0 Ok: queued as 5FDBD41C9C)
    Jun  1 21:58:17 cp postfix/qmgr[1763]: 514CA3FF93: removed
    Jun  1 21:58:17 cp postfix/smtp[4874]: connect to gmail-smtp-in.l.google.com[2404:6800:4003:c00::1a]:25: Network is unreachable
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have ipv6 connectivity?
     
  5. vinodbathi

    vinodbathi New Member HowtoForge Supporter

    i think i am not using ipv6, where can i check
    Edited
    As i see ipv6 is enabled but no ipv6 is assigned, only ipv4 is assigned
     
    Last edited: Jun 1, 2021
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Code:
    connect to gmail-smtp-in.l.google.com[2404:6800:4003:c00::1a]:25: Network is unreachable
    That shows your system connects to gmail using IPv6. If it is not configured this connection fails.
    Either set up IPv6 routing or make your postfix stop using IPv6.
    Internet Search Engines with
    Code:
    site:howtoforge.com disable IPv6
    find promising articles.
     
  7. vinodbathi

    vinodbathi New Member HowtoForge Supporter

    Change postfix config file "/etc/postfix/main.cf" to "inet_protocols = ipv4" and restarted postfix. still emails are not delivering.

    Code:
    [email protected]:/var/log# tail mail.log
    Jun  1 23:48:55 cp postfix/lmtp[11743]: BBA553FF93: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=0.62, delays=0.06/0.01/0/0.55, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10027): 250 2.0.0 Ok: queued as 5B0FE41CA7)
    Jun  1 23:48:55 cp postfix/qmgr[11055]: BBA553FF93: removed
    Jun  1 23:48:55 cp dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=11753, secured, session=<dxr+X7jD0qh/AAAB>
    Jun  1 23:48:55 cp dovecot: imap([email protected]): Logged out in=70 out=706
    Jun  1 23:48:55 cp dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=11756, secured, session=<fb8AYLjD1Kh/AAAB>
    Jun  1 23:48:55 cp dovecot: imap([email protected]): Logged out in=317 out=5440
    Jun  1 23:48:55 cp dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=11758, secured, session=<r9ABYLjD1qh/AAAB>
    Jun  1 23:48:55 cp dovecot: imap([email protected]): Logged out in=119 out=766
    Jun  1 23:48:56 cp postfix/smtp[11702]: connect to alt1.gmail-smtp-in.l.google.com[173.194.202.26]:25: Connection timed out
    Jun  1 23:48:56 cp postfix/smtp[11703]: connect to mx2.zoho.in[103.89.74.165]:25: Connection timed out
    Code:
    [email protected]:/var/log# tail mail.log
    Jun  1 23:49:25 cp postfix/smtp[11749]: connect to gmail-smtp-in.l.google.com[74.125.200.27]:25: Connection timed out
    Jun  1 23:49:25 cp postfix/smtp[11750]: connect to mx.zoho.in[103.89.74.165]:25: Connection timed out
    Jun  1 23:49:26 cp postfix/smtp[11702]: connect to alt2.gmail-smtp-in.l.google.com[142.250.115.26]:25: Connection timed out
    Jun  1 23:49:26 cp postfix/smtp[11703]: connect to mx3.zoho.in[103.89.74.165]:25: Connection timed out
    Jun  1 23:49:26 cp postfix/smtp[11703]: 9CC0E41CA2: to=<[email protected]>, relay=none, delay=622, delays=532/0.02/90/0, dsn=4.4.1, status=deferred (connect to mx3.zoho.in[103.89.74.165]:25: Connection timed out)
    Jun  1 23:49:55 cp postfix/smtp[11750]: connect to mx2.zoho.in[103.89.74.165]:25: Connection timed out
    Jun  1 23:49:55 cp postfix/smtp[11749]: connect to alt1.gmail-smtp-in.l.google.com[173.194.202.26]:25: Connection timed out
    Jun  1 23:49:56 cp postfix/smtp[11702]: connect to alt3.gmail-smtp-in.l.google.com[64.233.171.26]:25: Connection timed out
    Jun  1 23:49:56 cp dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=11785, secured, session=<Cu+jY7jDRKl/AAAB>
    Jun  1 23:49:56 cp dovecot: imap([email protected]): Logged out in=197 out=1820
    i added 2 mails, one is google and the other is zoho.
     
  8. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Probably port 25 connections are blocked. Check with your vps/colocation host and each router/connection along the path to the larger internet till you find the problem (it will be close to your endpoint, not many hops away).
     
  9. vinodbathi

    vinodbathi New Member HowtoForge Supporter

    Code:
    ufw status
    Status: inactive
    At cloud level, below ports are opened.
    Code:
    20,21,22,25,53,80,110,143,443,3306,8080,10000,40110-40210
     
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    My e-mail tutorial, link in signature below, has info on ports needed on an e-mail server. https://www.howtoforge.com/how-to-install-an-email-server-with-ispconfig-on-debian-10/#open-ports The comments of that tutorial have entry that tells how to test port is open.
     

Share This Page