Emails being rejected

Discussion in 'Installation/Configuration' started by digitalquill, Jun 3, 2009.

  1. digitalquill

    digitalquill New Member

    Hi

    I have an issue with my install, I have everything up following the Debian 4.0 instructions and all seems ok. I have setup a website/ftp access etc all ok, I have then setup a mail domain and a mailbox.

    I can access this remotly via Pop and Imap ok and see the welcome message

    however when I send emails to this mailbox I get it returned with:


    The following message to <office@allotmentclub.com> was undeliverable.
    The reason for the problem:
    5.1.0 - Unknown address error 550-'sorry, mail to that recipient is not accepted (#5.7.1)'



    Reporting-MTA: dns; smtpout.karoo.kcom.com

    Final-Recipient: rfc822;office@allotmentclub.com
    Action: failed
    Status: 5.0.0 (permanent failure)
    Remote-MTA: dns; [72.167.218.85]
    Diagnostic-Code: smtp; 5.1.0 - Unknown address error 550-'sorry, mail to that recipient is not accepted (#5.7.1)' (delivery attempts: 0)


    Any help would be great as I am now lost!

    Thanks
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Are you sure that dns entries have already been updated for your domain?
    Maybe mails are still sent to a different server and there is no such mailbox?

    Have a look in /var/log/mail.info and search for the sender address.
     
  3. digitalquill

    digitalquill New Member


    I suspect that you are right, although I think it is more me not understanding how to change the settings in godaddy to make it work, I have just changed the @ to the ipaddress of the ispconfig server. do I need to do anything more than that? Web traffic seems to go to it and I can login to the mailbox via the domain name.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    MX records point always to a domain name and not to an IP address.
     
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    till is right, you have to set the mx record to - lets say - mail.yourdomain.com and then set the ip of that DNS A - record to the server's ip.
     
  6. digitalquill

    digitalquill New Member

    I was just being too impatient! All working now... just got to solve auto-responder issue and all is great!

    Thanks for your help
     

Share This Page