Emailaccount & default MX: [email protected]

Discussion in 'General' started by clam, Dec 29, 2005.

  1. clam

    clam New Member

    I have installed the newest verions of ispconfig and sofar it works great on my server ! At the moment I have some problems with the emailaccount and also with the default mail.domain.tld mx in the domainrecord !

    If I build a new emailaccount the entry in the virtualusertable look like [email protected] but it should be [email protected] !

    If I add a domain with the dnsmanager there is a default mx (mail.domain.tld)entry for the localmailserver but if I add the domain over the ispmanager (new site) it doesn't work => www MX 10 domain.tld. instead of MX 10 mail.domain.tld. !

    Can anybody tell me how I can get rid of the www in all my emailadresse in the virtualusertable of postfix !

    thanks,
    florian
     
  2. clam

    clam New Member

    I add 2 users to a site.
    Does the following virtualusertable which was generated by ispconfig make any sense!

    [email protected] user1 ??
    [email protected] user2 ??
    [email protected] user1 ??
    [email protected] ??

    I don't need a email like [email protected]
    I like to have only [email protected] and [email protected]



    And here the Configuration File generated by ISPCONFIG :
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    # Version 1.0
    #
    ###################################
    [email protected] user1
    [email protected] user1
    [email protected] user1
    [email protected] user1
    [email protected] user2
    [email protected] user2
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Go to the website www.domain.tld and add a co-domain "domain.tld" with empty host field.
     
  4. clam

    clam New Member

    Thanks for your speedy reply !

    I did It like you told me in your previous reply !

    Some difficulties occurred :

    1. added a site with hostname www and a co-domain without a hostname !
    2 added one emailaddresse [email protected]

    The Emailadresse is working but why there are 4 records in the virtualusertable for one emailadresse :


    [email protected] tests
    [email protected] tests
    [email protected] tests
    [email protected] tests

    There should only be one Entry ([email protected] tests) !

    Is it a fault to write four line in virtualusertable ? You need only just: [email protected] tests


    best regards,

    Florian
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. clam

    clam New Member

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You get the email address that you have configured in the controlpanel. You dont have to use the alias for www that is configured by ISPConfig.
     

Share This Page