email tagged as spammy

Discussion in 'Server Operation' started by towershooter, Sep 18, 2008.

  1. towershooter

    towershooter New Member

    I am running Debian Etch according to The Perfect Setup. The email is set up according to the tutorial at:
    http://www.howtoforge.com/amavisd_postfix_debian_ubuntu.
    I have a the amavisd config as follows:

    Code:
    $sa_tag_level_deflt  = 0.00;  # add spam info headers if at, or above that level
    $sa_tag2_level_deflt = 3.00; # add 'spam detected' headers at that level
    $sa_kill_level_deflt = 10.00; # triggers spam evasive actions
    $sa_dsn_cutoff_level = 10;   # spam level beyond which a DSN is not sent
    
    and

    Code:
    $final_virus_destiny      = D_DISCARD;  # (data not lost, see virus quarantine)
    $final_banned_destiny     = D_PASS;   # D_REJECT when front-end MTA
    $final_spam_destiny       = D_PASS;
    $final_bad_header_destiny = D_PASS;     # False-positive prone (for spam)
    I am having a problem with a few emails being tagged as SPAMMY and not SPAM in the mail.log file. The mail never gets delivered, I found it sitting in the /var/lib/amavis/tmp folder. The mail.log file says the email is queued. I suspect it is in some sort of a quarantine. Here is the mail.log excerpt:
    Code:
    Sep 17 15:23:09 web1 postfix/smtpd[11496]: connect from mail-gx0-f19.google.com[209.85.217.19]
    Sep 17 15:23:09 web1 postfix/smtpd[11496]: D48823BC812: client=mail-gx0-f19.google.com[209.85.217.19]
    Sep 17 15:23:10 web1 postfix/cleanup[11500]: D48823BC812: message-id=<[email protected]>
    Sep 17 15:23:10 web1 postfix/qmgr[30685]: D48823BC812: from=<[email protected]>, size=14975, nrcpt=1 (queue active)
    Sep 17 15:23:25 web1 postfix/smtpd[11505]: connect from localhost.localdomain[127.0.0.1]
    Sep 17 15:23:25 web1 postfix/smtpd[11505]: 0E1E63BC813: client=localhost.localdomain[127.0.0.1]
    Sep 17 15:23:25 web1 postfix/cleanup[11500]: 0E1E63BC813: message-id=<[email protected]>
    Sep 17 15:23:25 web1 postfix/smtpd[11505]: disconnect from localhost.localdomain[127.0.0.1]
    Sep 17 15:23:25 web1 postfix/qmgr[30685]: 0E1E63BC813: from=<[email protected]>, size=15708, nrcpt=1 (queue active)
    Sep 17 15:23:25 web1 amavis[5935]: (05935-05) Passed SPAMMY, [209.85.217.19] [64.198.1.59] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: aOiTHhEdCupT, Hits: 4.064, queued_as: 0E1E63BC813, 15008 ms
    Sep 17 15:23:25 web1 postfix/smtp[11501]: D48823BC812: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=15, delays=0.28/0.01/0/15, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=05935-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0E1E63BC813)
    Sep 17 15:23:25 web1 postfix/qmgr[30685]: D48823BC812: removed
    Sep 17 15:23:25 web1 postfix/local[11506]: 0E1E63BC813: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.13, delays=0.06/0.01/0/0.05, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail)
    Sep 17 15:23:25 web1 postfix/qmgr[30685]: 0E1E63BC813: removed
    Sep 17 15:23:40 web1 postfix/smtpd[11496]: disconnect from mail-gx0-f19.google.com[209.85.217.19]
    Does anyone know how how to get the email from quarantine or why it is listed as SPAMMY and not SPAM? How do I let the SPAMMY mail through to clients?

    Any help would be greatly appreciated.

    Kelly
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you set up a quarantine in your amavisd configuration?
     
  3. towershooter

    towershooter New Member

    Thanks for the answer. I would have to say no I do not have a quarantine set up. I set up amavisd according to http://www.howtoforge.com/amavisd_postfix_debian_ubuntu. I have looked for a modification tutorial to add a quarantine but have yet to find one. Any idea where one is located?

    Thanks again

    Kelly
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It must be somewhere in your amavisd configuration (don't know the exact position...).
     

Share This Page