email stats stopped working (traffic)

Discussion in 'General' started by jokerdes, Oct 11, 2017.

  1. jokerdes

    jokerdes New Member

    Hello,
    I'd like to get some help.
    My ispconfig version is 3.1.7.
    Upgraded several times, last time i reconfigured services.
    Where do I start debugging?
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    It looks like mail stats are probably gathered by an ispconfig cronjob (/usr/local/ispconfig/server/lib/classes/cron.d/100-mailbox_stats.inc.php) - you could make sure you have cron running on that server and that the ispconfig cronjob is setup (ie. 'crontab -l' shows an entry for cron.sh). You could try running that cronjob manually from the command line (/usr/local/ispconfig/server/cron_debug.php --cronjob=100-mailbox_stats.inc.php) and see if you find anything.
     
  3. jokerdes

    jokerdes New Member

    Thank you for your answer.
    The cronjob contains server.sh and cron.sh. Cron running and cannot see any error in logs.
    When manually run it says "finished".
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This might be a logging issue as well. Check that the system mail log file is working (gets updates) as the ISPConfig cronjob reads the traffic data from there.
     
  5. jokerdes

    jokerdes New Member

    Solved. :)
    There was a problem with mail_log_parser.state, deleted and rerun the mailbox_stats cron solves the problem.
    Thank you for all.
     
    till and ztk.me like this.

Share This Page