email setup using godaddy domain

Discussion in 'Installation/Configuration' started by ariban99, Jun 15, 2015.

  1. ariban99

    ariban99 Member

    Hi,
    I read so much online and cant find anything proper that helps me to set up my email.
    i host my domain on godaddy.com, i changed the dns on godaddy to host @ and pointing to my ip address and then i made a new host called ns and pointing to my ip as well. so for website its works and it loads etc...
    i then set everything else, mx records etc... to point to @
    however when it comes to seting up email its not working, if i email from my gmail to the email i set up in ispconfig it comes back saying cant find that email address and i also cant send out from the new created email.
    what am i doing wrong?
    please help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    First check with e.g. intodns.com that the mx record really points to your ispconfig server. Then take a look into the mail.log file if there are any errors inside.
     
  3. ariban99

    ariban99 Member

    Hi Till,
    Thank you for responding and your help. I am completely new to linux and i have no idea how to do anything. even when you say look in mail.log i dont know how to do that, please tell me what do to for that! i wish there was a tutorial for dummies!!
    i simply followed these instructions to the letter https://www.howtoforge.com/perfect-...l-php-pureftpd-postfix-dovecot-and-ispconfig3 and website is working great!
    i am having problems with understanding how to get email to work.
    I went to the website intodns.com and typed in haadama.com and i get results i dont understand.
    i host my domain names on godaddy.com and based on what i read in different places i did the following:
    under A
    host @ points to my ip 50.138.64.164
    host ns1 points to my ip
    under Cname
    host email points to mail.haadama.com
    host ftp and www point to @
    under MX
    priority 10 host @ points to mail.haadama.com
    and priority 0 host @ points to mail.haadama.com

    in ispconfig i created a new dns using wizard, under domain i put haadama.com under ns1 i put ns1.haadama.com and under ns2 i put ns2.haadama.com and ip address i put my internet public ip address.

    when i login to roundcube i sent myself an email to test to [email protected] and also to my personal hotmail address but nothing comes in, not to myself or to hotmail. also in outlook i get error messages trying to connect to the email i set up.
    when i send from my business email to my new test email of [email protected] i get the following email return error message:
    Hi. This is the qmail-send program at vps-1108181-11679.manage.myhosting.com.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.
    <[email protected]>:
    Sorry, I couldn't find a mail exchanger or IP address. (#5.4.4)
    --- Below this line is a copy of the message.
    ....
     
    Last edited: Jun 15, 2015
  4. ariban99

    ariban99 Member

    i read online to find the mail log, here are the results:
    [[email protected] etc]# tail -n40 /var/log/maillog
    Jun 15 12:00:02 webserver postfix/smtpd[17824]: lost connection after CONNECT from localhost[::1]
    Jun 15 12:00:02 webserver postfix/smtpd[17824]: disconnect from localhost[::1]
    Jun 15 12:00:02 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<PbPqjJAYBQAAAAAAAAAAAAAAAAAAAAAB>
    Jun 15 12:02:33 webserver postfix/qmgr[2361]: 744C483B3CBA: from=<[email protected]>, size=1009, nrcpt=1 (queue active)
    Jun 15 12:02:33 webserver postfix/smtp[17925]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jun 15 12:02:33 webserver postfix/smtp[17925]: 744C483B3CBA: to=<[email protected]>, relay=none, delay=2268, delays=2268/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 15 12:05:02 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<mr3MnpAYEgAAAAAAAAAAAAAAAAAAAAAB>
    Jun 15 12:05:02 webserver postfix/smtpd[18008]: connect from localhost[::1]
    Jun 15 12:05:02 webserver postfix/smtpd[18008]: lost connection after CONNECT from localhost[::1]
    Jun 15 12:05:02 webserver postfix/smtpd[18008]: disconnect from localhost[::1]
    Jun 15 12:05:02 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<AxrNnpAYDgAAAAAAAAAAAAAAAAAAAAAB>
    Jun 15 12:07:33 webserver postfix/qmgr[2361]: 5205483B3CA2: from=<[email protected]>, size=416, nrcpt=1 (queue active)
    Jun 15 12:07:33 webserver postfix/qmgr[2361]: ECA1083B3CA7: from=<[email protected]>, size=416, nrcpt=1 (queue active)
    Jun 15 12:07:33 webserver postfix/qmgr[2361]: 4446083B3CC0: from=<[email protected]>, size=3775, nrcpt=1 (queue active)
    Jun 15 12:07:33 webserver postfix/smtp[18080]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jun 15 12:07:33 webserver postfix/smtp[18081]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jun 15 12:07:33 webserver postfix/smtp[18080]: 5205483B3CA2: to=<[email protected]>, relay=none, delay=4685, delays=4685/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 15 12:07:33 webserver postfix/smtp[18080]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jun 15 12:07:33 webserver postfix/smtp[18081]: ECA1083B3CA7: to=<[email protected]>, relay=none, delay=4561, delays=4561/0.03/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 15 12:07:33 webserver postfix/smtp[18080]: 4446083B3CC0: to=<[email protected]>, orig_to=<[email protected]>, relay=none, delay=2345, delays=2345/0.04/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 15 12:07:57 webserver clamd[1978]: SelfCheck: Database status OK.
    Jun 15 12:10:01 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<jEGssJAYHgAAAAAAAAAAAAAAAAAAAAAB>
    Jun 15 12:10:01 webserver postfix/smtpd[18170]: connect from localhost[::1]
    Jun 15 12:10:02 webserver postfix/smtpd[18170]: lost connection after CONNECT from localhost[::1]
    Jun 15 12:10:02 webserver postfix/smtpd[18170]: disconnect from localhost[::1]
    Jun 15 12:10:02 webserver dovecot: pop3-login: Disconnected (no auth attempts in 1 secs): user=<>, rip=::1, lip=::1, secured, session=<nK6ssJAYGgAAAAAAAAAAAAAAAAAAAAAB>
    Jun 15 12:10:53 webserver postfix/scache[18086]: statistics: start interval Jun 15 12:07:33
    Jun 15 12:10:53 webserver postfix/scache[18086]: statistics: domain lookup hits=0 miss=1 success=0%
    Jun 15 12:10:53 webserver postfix/scache[18086]: statistics: address lookup hits=0 miss=1 success=0%
    Jun 15 12:12:33 webserver postfix/qmgr[2361]: 14EF283B3CB1: from=<[email protected]>, size=1031, nrcpt=1 (queue active)
    Jun 15 12:12:33 webserver postfix/qmgr[2361]: DBD8B83B3CB6: from=<[email protected]>, size=1017, nrcpt=1 (queue active)
    Jun 15 12:12:33 webserver postfix/smtp[18244]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jun 15 12:12:33 webserver postfix/smtp[18245]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
    Jun 15 12:12:33 webserver postfix/smtp[18244]: 14EF283B3CB1: to=<[email protected]>, relay=none, delay=4789, delays=4789/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 15 12:12:33 webserver postfix/smtp[18245]: DBD8B83B3CB6: to=<[email protected]>, relay=none, delay=4730, delays=4730/0.03/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jun 15 12:15:01 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<NeOIwpAYKQAAAAAAAAAAAAAAAAAAAAAB>
    Jun 15 12:15:01 webserver postfix/smtpd[18333]: connect from localhost[::1]
    Jun 15 12:15:01 webserver postfix/smtpd[18333]: lost connection after CONNECT from localhost[::1]
    Jun 15 12:15:01 webserver postfix/smtpd[18333]: disconnect from localhost[::1]
    Jun 15 12:15:01 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<SXKJwpAYJQAAAAAAAAAAAAAAAAAAAAAB>
    [[email protected] etc]#
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The amavisd service is not running. Run:

    service amavisd start

    to start it.
     
  6. ariban99

    ariban99 Member

    this is the error i get:
    service amavisd start
    Redirecting to /bin/systemctl start amavisd.service
    Job for amavisd.service failed. See 'systemctl status amavisd.service' and 'journalctl -xn' for details.

    systemctl status amavisd.service -l
    amavisd.service - Amavisd-new is an interface between MTA and content checkers.
    Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled)
    Active: failed (Result: start-limit) since Mon 2015-06-15 12:38:10 EDT; 1min 39s ago
    Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 19145 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf (code=exited, status=255)

    Jun 15 12:38:10 webserver systemd[1]: amavisd.service: control process exited, code=exited status=255
    Jun 15 12:38:10 webserver systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Jun 15 12:38:10 webserver systemd[1]: Unit amavisd.service entered failed state.
    Jun 15 12:38:10 webserver systemd[1]: amavisd.service holdoff time over, scheduling restart.
    Jun 15 12:38:10 webserver systemd[1]: Stopping Amavisd-new is an interface between MTA and content checkers....
    Jun 15 12:38:10 webserver systemd[1]: Starting Amavisd-new is an interface between MTA and content checkers....
    Jun 15 12:38:10 webserver systemd[1]: amavisd.service start request repeated too quickly, refusing to start.
    Jun 15 12:38:10 webserver systemd[1]: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Jun 15 12:38:10 webserver systemd[1]: Unit amavisd.service entered failed state.
     
  7. ariban99

    ariban99 Member

    also does this mean my dns is correct and working?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    One step after another. your mail log part does not contain lines that clerly indicate that, so fisrt resolve the amavis error.

    try:

    service amavisd restart

    instead. And how much ram does your server has?
     
  9. ariban99

    ariban99 Member

    service amavisd restart
    Redirecting to /bin/systemctl restart amavisd.service
    Job for amavisd.service failed. See 'systemctl status amavisd.service' and 'journalctl -xn' for details.
    I have 12 gb of ram
     
  10. ariban99

    ariban99 Member

    i originally had 4gb of ram then i added 8 more, i dont know if this has anything to do with the problem?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    No, thats should not be the reasn for the problem. I just asked for the ram amount as some pople try to run a full email, web, ftp and dns server on just 500mb ram and that will not fit and will cause serbice start errors as there is not enough ram for all services.

    Plesae try a amavisd restart again and then check the maillog file for amavis related errors.
     
  12. ariban99

    ariban99 Member

    here is the log:
    [[email protected] webserver]# tail -n40 /var/log/maillog
    Jun 16 07:20:28 webserver postfix/error[2361]: warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)
    Jun 16 07:20:28 webserver postfix/error[2361]: warning: mysql:/etc/postfix/mysql -virtual_relaydomains.cf: table lookup problem
    Jun 16 07:20:28 webserver postfix/error[2361]: warning: 744C483B3CBA: flush serv ice failure
    Jun 16 07:20:28 webserver postfix/error[2362]: warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)
    Jun 16 07:20:28 webserver postfix/error[2362]: warning: mysql:/etc/postfix/mysql -virtual_relaydomains.cf: table lookup problem
    Jun 16 07:20:28 webserver postfix/error[2362]: warning: 4446083B3CC0: flush serv ice failure
    Jun 16 07:20:28 webserver postfix/error[2360]: 6F4DF82B5B05: to=<[email protected] >, relay=none, delay=72275, delays=72274/1.1/0/0.2, dsn=4.4.1, status=deferred ( delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connectio n refused)
    Jun 16 07:20:28 webserver postfix/error[2257]: ECA1083B3CA7: to=<[email protected] om>, relay=none, delay=73737, delays=73736/1.1/0/0.21, dsn=4.4.1, status=deferre d (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connec tion refused)
    Jun 16 07:20:28 webserver postfix/error[2257]: warning: mysql:/etc/postfix/mysql -virtual_relaydomains.cf: table lookup problem
    Jun 16 07:20:28 webserver postfix/error[2257]: warning: ECA1083B3CA7: flush serv ice failure
    Jun 16 07:20:28 webserver postfix/error[2360]: warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)
    Jun 16 07:20:28 webserver postfix/error[2360]: warning: mysql:/etc/postfix/mysql -virtual_relaydomains.cf: table lookup problem
    Jun 16 07:20:28 webserver postfix/error[2360]: warning: 6F4DF82B5B05: flush serv ice failure
    Jun 16 07:20:28 webserver postfix/error[2324]: DBD8B83B3CB6: to=<[email protected] >, relay=none, delay=73606, delays=73605/1.1/0/0.22, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connecti on refused)
    Jun 16 07:20:28 webserver postfix/error[2324]: warning: mysql:/etc/postfix/mysql -virtual_relaydomains.cf: table lookup problem
    Jun 16 07:20:28 webserver postfix/error[2324]: warning: DBD8B83B3CB6: flush serv ice failure
    Jun 16 07:20:41 webserver clamd[2060]: Loaded 3841875 signatures.
    Jun 16 07:20:42 webserver clamd[2060]: LOCAL: Unix socket file /var/run/clamd.am avisd/clamd.sock
    Jun 16 07:20:42 webserver clamd[2060]: LOCAL: Setting connection queue length to 200
    Jun 16 07:20:42 webserver clamd[2060]: Limits: Global size limit set to 10485760 0 bytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: File size limit set to 26214400 b ytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: Recursion level limit set to 16.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: Files limit set to 10000.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxEmbeddedPE limit set to 104857 60 bytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxHTMLNormalize limit set to 104 85760 bytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxHTMLNoTags limit set to 209715 2 bytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxScriptNormalize limit set to 5 242880 bytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxZipTypeRcg limit set to 104857 6 bytes.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxPartitions limit set to 50.
    Jun 16 07:20:42 webserver clamd[2060]: Limits: MaxIconsPE limit set to 100.
    Jun 16 07:20:42 webserver clamd[2060]: Archive support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: Algorithmic detection enabled.
    Jun 16 07:20:42 webserver clamd[2060]: Portable Executable support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: ELF support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: Mail files support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: OLE2 support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: PDF support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: SWF support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: HTML support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: Self checking every 600 seconds.
     
  13. ariban99

    ariban99 Member

    i ran the amavisd restart a second time and here are the logs for that:
    tail -n40 /var/log/maillog
    Jun 16 07:20:42 webserver clamd[2060]: HTML support enabled.
    Jun 16 07:20:42 webserver clamd[2060]: Self checking every 600 seconds.
    Jun 16 07:23:48 webserver postfix/scache[2356]: statistics: start interval Jun 16 07:20:28
    Jun 16 07:23:48 webserver postfix/scache[2356]: statistics: domain lookup hits=0 miss=2 success=0%
    Jun 16 07:23:48 webserver postfix/scache[2356]: statistics: address lookup hits=0 miss=2 success=0%
    Jun 16 07:25:02 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<SnBO06AYYAAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:25:02 webserver postfix/smtpd[2796]: connect from localhost[::1]
    Jun 16 07:25:02 webserver postfix/smtpd[2796]: lost connection after CONNECT from localhost[::1]
    Jun 16 07:25:02 webserver postfix/smtpd[2796]: disconnect from localhost[::1]
    Jun 16 07:25:02 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<O7BP06AYgQAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:30:01 webserver postfix/smtpd[2968]: connect from localhost[::1]
    Jun 16 07:30:01 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<nd8g5aAYZwAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:30:01 webserver postfix/smtpd[2968]: lost connection after CONNECT from localhost[::1]
    Jun 16 07:30:01 webserver postfix/smtpd[2968]: disconnect from localhost[::1]
    Jun 16 07:30:01 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<EB0h5aAYiAAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:30:42 webserver clamd[2060]: No stats for Database check - forcing reload
    Jun 16 07:30:43 webserver clamd[2060]: Reading databases from /var/lib/clamav
    Jun 16 07:30:49 webserver clamd[2060]: Database correctly reloaded (3841875 signatures)
    Jun 16 07:35:02 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<JbAM96AYbgAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:35:02 webserver postfix/smtpd[3124]: connect from localhost[::1]
    Jun 16 07:35:02 webserver postfix/smtpd[3124]: lost connection after CONNECT from localhost[::1]
    Jun 16 07:35:02 webserver postfix/smtpd[3124]: disconnect from localhost[::1]
    Jun 16 07:35:02 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<HCIN96AYjwAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:40:01 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<TNnnCKEYdQAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:40:01 webserver postfix/smtpd[3285]: connect from localhost[::1]
    Jun 16 07:40:01 webserver postfix/smtpd[3285]: lost connection after CONNECT from localhost[::1]
    Jun 16 07:40:01 webserver postfix/smtpd[3285]: disconnect from localhost[::1]
    Jun 16 07:40:01 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<oy/oCKEYlgAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:40:49 webserver clamd[2060]: SelfCheck: Database status OK.
    Jun 16 07:45:01 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<TwjEGqEYfAAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:45:01 webserver postfix/smtpd[3439]: connect from localhost[::1]
    Jun 16 07:45:01 webserver postfix/smtpd[3439]: lost connection after CONNECT from localhost[::1]
    Jun 16 07:45:01 webserver postfix/smtpd[3439]: disconnect from localhost[::1]
    Jun 16 07:45:01 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<kGvEGqEYnQAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:50:02 webserver postfix/smtpd[3597]: connect from localhost[::1]
    Jun 16 07:50:02 webserver dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<eTCvLKEYgwAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:50:02 webserver postfix/smtpd[3597]: lost connection after CONNECT from localhost[::1]
    Jun 16 07:50:02 webserver postfix/smtpd[3597]: disconnect from localhost[::1]
    Jun 16 07:50:02 webserver dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<nXCvLKEYpAAAAAAAAAAAAAAAAAAAAAAB>
    Jun 16 07:50:49 webserver clamd[2060]: SelfCheck: Database status OK.
     
  14. ariban99

    ariban99 Member

    also if you want to login to my server, i would be more than happy to provide you with the rsa key (in a private email or message of course), just please tell me the steps you take in fixing this issues so i know for future and i can learn more about centos/linux which i very much want to learn more.
    thank you
     

Share This Page