email server setup issue

Discussion in 'Installation/Configuration' started by tenchi21, Mar 3, 2013.

  1. tenchi21

    tenchi21 New Member

    I recently decided to start hosting my own sites again like I used to. But I have ran into a problem and can not figure it out on my own so far. I got a final data dump from my old host but they used cpanel instead of ispconfig so I can't do a quick import. What I need to know how to do is

    they used details like this for emails

    [email protected]

    and my ISPconfig 3 keeps making it as

    [email protected]

    even when I try to change it it seems to revert back to

    any ideas ?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. tenchi21

    tenchi21 New Member

    what I have set are

    ISPConfig 3 Settings
    Mail Domain
    domain: domain.tld
    active: check

    Email: username @ domain.tld
    enable receiving: check


    IMAP Mail Server
    Server name: mail.domain.tld
    user name: [email protected]

    when i try to receive or send mail from that account it times out or bounces back.

    edit: I just logged into the webmail page and tried to send a test email from that account to a generic yahoo account of mine and it failed. says "ERROR: Message not sent. Server replied: " and nothing else after that.
    Last edited: Mar 4, 2013
  4. tenchi21

    tenchi21 New Member

    so does this mean that know one knows the answer ? on how to fix this ?
  5. Parsec

    Parsec New Member

    Not enough info to decipher

    You need to watch your mail.log next time you try and send one from webmail and see what the mailserver does with it. What the mailserver says is important.
  6. tenchi21

    tenchi21 New Member

    okay here is my mail.log details from the recent tests

  7. Parsec

    Parsec New Member

    Mar 11 14:56:23 server1 postfix/smtp[4791]: ED044C0D82: to=<[email protected]>, relay=none, delay=41342, delays=41192/0.09/150/0, dsn=4.4.1, status=deferred (connect to[]:25: Connection timed out) 
    Something wrong with your internet setup, routing or the interface setting in postfix. Try pinging that server from the console, if it responds then it's possible it's a postfix interface issue. Also try sendng email to somewhere else.
  8. tenchi21

    tenchi21 New Member

    from my personal computer
    $ ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_req=1 ttl=50 time=79.6 ms
    64 bytes from icmp_req=2 ttl=50 time=79.1 ms
    64 bytes from icmp_req=3 ttl=50 time=80.6 ms
    64 bytes from icmp_req=4 ttl=50 time=79.0 ms
    --- ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3004ms
    rtt min/avg/max/mdev = 79.011/79.624/80.658/0.679 ms

    from the server
    $ ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_req=1 ttl=50 time=80.7 ms
    64 bytes from icmp_req=2 ttl=50 time=95.5 ms
    64 bytes from icmp_req=3 ttl=50 time=95.9 ms
    64 bytes from icmp_req=4 ttl=50 time=79.4 ms
    --- ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3003ms
    rtt min/avg/max/mdev = 79.429/87.904/95.939/7.840 ms
  9. Parsec

    Parsec New Member

    /etc/postfic/ - What's the values for:


    And.. you wouldn't happen to be on an intenet connection who's provider blocks port 25 would you?
    Check by using at the console:

    telnet 25
  10. tenchi21

    tenchi21 New Member

    Last edited: Mar 12, 2013
  11. Parsec

    Parsec New Member

    My mistake, was a typo - should be /etc/postfix/

    If comcast blocks port 25 then you are going to have trouble sending any mail via postfix. 25 is the smtp protocol port.
    When Comcast tell you to use port 465 instead they are referring to when you use an email client, not a mailserver.

    Your only hope is that Comcast have a mail server available that listens on port 25 so then you can use it as a relay (ie: your server becomes a "smarthost").

    Sorry, I am not familiar with how Comcast runs their network, so I can't really help you much in this.
  12. tenchi21

    tenchi21 New Member

    okay in that file I have these set

    inet_interfaces = all
    inet_protocols = all
    mynetworks = [::1]/128
  13. Parsec

    Parsec New Member

    Yep, so that's ok. But your problem is going to be Comcast blocking port 25.

    I don't have any other advice to help with that.
  14. tenchi21

    tenchi21 New Member

    can I set my mail server to use another port and then be able to send/receive mail that way ? been trying to figure this out for about 11 days now lol.
    Never thought that comcast could be the cause.

  15. Parsec

    Parsec New Member

    Not really no. Because all the mail servers on the internet are listening on port 25 (smtp) for incoming mail.

    The use of other ports, like 465, 587 etc are generally for user access depending on the services provided to their own clients.

    Your best bet is to do a few google searches and see if you can find other people trying to run mail servers behind Comcast and see what they did. The easiest way is the smarthost way - if you can find a comcast server to relay through.

Share This Page