email server problems

Discussion in 'Installation/Configuration' started by able, Oct 14, 2020.

  1. able

    able New Member HowtoForge Supporter

    I am installing perfect server with roundcube & ispconfig 3.
    It is very good instruction.
    Much easy then other variants.
    I have problem installing by your instruction on centos 7/8 and debian 9/10 or ubuntu 20.04. installing on digital ocean vps, hetzner vps, linode. Now testing on my own server. istallation going ok usualy.
    But when i start mail server - add mail domain, then add mail box - mailbox is empty in incoming. outcome email is normal. and normal going to other servers.
    What i am doing wrong and how to fix it?

    also roundcube shows error 250 when trying to send mail.
    i`ve installed on this intruction about month or two before and has no errors. do not understand what to show and what to do.

    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] OS version is Ubuntu 18.04.5 LTS

    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1dev
     
  2. able

    able New Member HowtoForge Supporter

    also
    debian 10.0.6 on my server trying to install perfect server
    installation errors
    Code:
     dpkg-reconfigure dash
    bash: dpkg-reconfigure: command not found
    
    Code:
     a2enmod suexec rewrite ssl actions include dav_fs dav auth_digest cgi headers actions proxy_fcgi alias
    bash: a2enmod: command not found
    
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you installed 6 systems with different OS each time?
    I do not use the development version, the released stable version is supported and works reliably. The development versions have bad days when they just do not work. So if you want a system that works, do not use the development version. It is meant for those that do ISPConfig development or do troubleshooting to find bugs before release.
    If I were you, I would install a 7th system, this time with release ISPConfig version 3.1.15.
    If you really want to fix the installation you have now, I do not understand this:
    What is not working? When you create a mailbox, it should have one message right away, automatically sent by ISPConfig. So if mailbox is completely empty something is wrong. Is this what you meant? Or that mailbox can not receive e-mails?
    Please show complete htf_report.txt, not just short excerpt. If what you showed was all you got, remember to run the script as root user or sudo -s first.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You need to run those commands, as also most of the perfect server guide, as root. Use 'sudo -i' or 'su -' to become root and try again.
     
    Th0m likes this.
  5. Steini86

    Steini86 Active Member

    Have a look at the mail log. Can be accessed via ISPC interface -> Monitor -> Mail log
     

Share This Page