Email seems to work in roundcube but not Outlook or Thunderbird

Discussion in 'Installation/Configuration' started by Yarnell, Jan 27, 2021.

  1. Yarnell

    Yarnell Member

    Was up all night trying to figure this out but it just aint happening. Soooo close... Email works when I login to roundcube (ssl too) but when I try to connect via outlook or thunderbird it just fails.

    When I telnet/openssh from the host computer it works:
    Code:
    telnet xxx.xx 143
    openssl s_client -crlf -connect xxx.xx:993
    * OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SEPCIAL-USE XLIST LITERAL+ STARTTLS AUTH=PLAIN AUTH=LOGIN] Dovecot (Debian) ready.
    When I try from a different computer it fails.
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Have you set up the correct DNS records to connect to your server?
     
  3. Yarnell

    Yarnell Member

    as of right now I have 2 sets of dns records. those in godaddy and the ones in ispconfig. for the ones in godaddy I have 4 A records pointing to my ip, 2 NS records pointing to the ones godaddy provided and an MX pointing to my ip. in ispconfig I have 3 a records pointing to my internal ip, my NS records point to the godaddy ones and my MX points to mail.abc.ca
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    I saw you sent me a PM. Please keep the conversation here so others can help aswell.

    Why are you using a zone with GoDaddy and in ISPConfig? This can lead to confusing situations, so you should only have the zone on the nameservers you use..
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    If it's not a dns issue, next thing to look at is that your firewalls (local and network) and port forwards are correct.
     
  6. Yarnell

    Yarnell Member

    Th0m... OK, I just didn't wanna advertise my numbers... There is no reason for the double dns, it was just the default settings that ispconfig setup. I haven't had the time to sit down and configure them yet :) So your saying I should only have the mx records on the active name server? or are you saying I should get rid of the ispconfig zone all together?

    Jesse... you got it, I double checked my firewall but I couldn't see anything that stood out. something told me to turn off fail2ban and BOOYAH, it started working... Now I just need to figure out why it was banning me. Much Much Thanks.

    I have to say this is a great forum and excellent product thus far... I'm excited... Thanks again folks.
     
    Th0m likes this.
  7. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    If you aren't going to use ISPConfig for your nameservers, remove the whole zone.

    You can view the banned IP list:
    Code:
    fail2ban-client status dovecot
    and unban:
    Code:
    fail2ban-client set dovecot unbanip 1.2.3.4
    (replace the jailname and IP with the correct jail and IP)
     
  8. Yarnell

    Yarnell Member

    perfect... thanks
     

Share This Page