Email seemingly not working...

Discussion in 'Installation/Configuration' started by Duplex, Apr 17, 2006.

  1. Duplex

    Duplex New Member

    I'm having a very similar error as this thread.
    http://www.howtoforge.com/forums/showthread.php?t=371

    let me start out by saying the forwards work, I setup a seperate server with only a standalone mail server running to test router and network config and it worked fine. However I'd really like to use ISPconfig for everything.

    Here's the general email I get back after trying to use another external address to send to this machine.

    My forwards are setup, my domain is forwarded correctly, and firewall's do not seem to be blocking anything. I use debian 3.1/sarge. I used the perfect setup guide and followed every single step to the letter in setting my machine up from a fresh format to it running now.

    I am finding nothing in the documentation thus far that's helped so if anyone could shed some light that would be great.
     
  2. Hans

    Hans Moderator

    Are the MX-records within the DNS-records of your domain-registrar pointing to your server?

    In your router:
    Did you setup portforwarding and open ports within your router correctly?
    (look at ports 25 & 110).

    Hans
     
  3. Duplex

    Duplex New Member

    ^ read above...

    That information has been posted in my original post, when I originally posted it.
     
  4. falko

    falko Super Moderator

    Code:
    <duplex@gquit.com>: host 209.193.68.93[209.193.68.93] said: 554
    <duplex@gquit.com>: Relay access denied (in reply to RCPT TO command)
    Please make sure you enabled "Server requires authentication." in your email client.
    Is 209.193.68.93 your public IP address, or is it some other server?
     
  5. Duplex

    Duplex New Member

    That would be my public static IP address, which works when I setup a standalone e-mail server. Also my client is setup correctly.
     
    Last edited: Apr 18, 2006
  6. Duplex

    Duplex New Member

    Does anyone have an actual walk through of creating your first client, site, email addresses for this software? I have yet to see any definitive documentation describing the use of the individual components of this compilation of software. If I knew how to use it I'd be more than happy to help but as you can see I am currently unable to complete the simple tasks.
     
  7. till

    till Super Moderator

    There is no howto that describes the steps.

    The documentation describing all features and what to enter in which input field is here:

    http://www.ispconfig.org/documentation.htm

    The steps are as follows:

    1) add a reseller
    2) add a client
    3) add a website
    4) Add an email user wehere you check the "administrator" checkbox. This email user will be the site administrator. When you use the username and poswword to connect from an FRT client, you will be able to upload your html pages.
    5) add as many other email users as youu need.
     
  8. falko

    falko Super Moderator

  9. Duplex

    Duplex New Member

    I've tried every OE setup in the book nothing works. Thus far my mail logs are showing that the email is not relaying...


    Code:
    Apr 18 23:20:45 main postfix/qmgr[3879]: 7B57E70401C: from=<>, size=2403, nrcpt=1 (queue active)
    Apr 18 23:20:45 main postfix/smtp[1156]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 18 23:20:45 main postfix/smtp[1156]: 7B57E70401C: to=<admispconfig@tech-xpress.com>, relay=none, delay=26000, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 18 23:37:25 main postfix/qmgr[3879]: 2259E704021: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 18 23:37:25 main postfix/qmgr[3879]: 2CDF570401E: from=<>, size=2403, nrcpt=1 (queue active)
    Apr 18 23:37:26 main postfix/smtp[1376]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 18 23:37:26 main postfix/smtp[1377]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 18 23:37:26 main postfix/smtp[1376]: 2259E704021: to=<admispconfig@tech-xpress.com>, relay=none, delay=386342, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 18 23:37:26 main postfix/smtp[1377]: 2CDF570401E: to=<admispconfig@tech-xpress.com>, relay=none, delay=28000, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 18 23:54:05 main postfix/qmgr[3879]: 534F270401D: from=<root@tech-xpress.com>, size=1862, nrcpt=1 (queue active)
    Apr 18 23:54:05 main postfix/qmgr[3879]: BF191704020: from=<admispconfig@tech-xpress.com>, size=610, nrcpt=1 (queue active)
    Apr 18 23:54:05 main postfix/qmgr[3879]: A2203704024: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 18 23:54:05 main postfix/smtp[1615]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 18 23:54:05 main postfix/smtp[1616]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 18 23:54:05 main postfix/smtp[1617]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 18 23:54:05 main postfix/smtp[1615]: 534F270401D: to=<root@tech-xpress.com>, orig_to=<root>, relay=none, delay=396917, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 18 23:54:05 main postfix/smtp[1616]: BF191704020: to=<support@tech-xpress.com>, relay=none, delay=387320, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 18 23:54:05 main postfix/smtp[1617]: A2203704024: to=<admispconfig@tech-xpress.com>, relay=none, delay=382820, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:10:45 main postfix/qmgr[3879]: BFC93704023: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 19 00:10:45 main postfix/qmgr[3879]: CB1E3704025: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 19 00:10:45 main postfix/qmgr[3879]: EEAFD704026: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 19 00:10:45 main postfix/qmgr[3879]: 7BCF9704022: from=<customdesign@vcn.com>, size=1576, nrcpt=1 (queue active)
    Apr 19 00:10:45 main postfix/smtp[1839]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:10:45 main postfix/smtp[1841]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:10:45 main postfix/smtp[1842]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:10:45 main postfix/smtp[1843]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:10:45 main postfix/smtp[1839]: BFC93704023: to=<admispconfig@tech-xpress.com>, relay=none, delay=383827, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:10:45 main postfix/smtp[1841]: CB1E3704025: to=<admispconfig@tech-xpress.com>, relay=none, delay=383704, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:10:45 main postfix/smtp[1842]: EEAFD704026: to=<admispconfig@tech-xpress.com>, relay=none, delay=381884, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:10:45 main postfix/smtp[1843]: 7BCF9704022: to=<web1_duplex@tech-xpress.com>, orig_to=<duplex@gquit.com>, relay=none, delay=381292, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:27:25 main postfix/qmgr[3879]: 7B57E70401C: from=<>, size=2403, nrcpt=1 (queue active)
    Apr 19 00:27:26 main postfix/smtp[2051]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:27:26 main postfix/smtp[2051]: 7B57E70401C: to=<admispconfig@tech-xpress.com>, relay=none, delay=30001, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:44:05 main postfix/qmgr[3879]: 2259E704021: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 19 00:44:05 main postfix/qmgr[3879]: 2CDF570401E: from=<>, size=2403, nrcpt=1 (queue active)
    Apr 19 00:44:05 main postfix/smtp[2263]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:44:05 main postfix/smtp[2264]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 00:44:05 main postfix/smtp[2263]: 2259E704021: to=<admispconfig@tech-xpress.com>, relay=none, delay=390341, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 00:44:05 main postfix/smtp[2264]: 2CDF570401E: to=<admispconfig@tech-xpress.com>, relay=none, delay=31999, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 01:00:45 main postfix/qmgr[3879]: 534F270401D: from=<root@tech-xpress.com>, size=1862, nrcpt=1 (queue active)
    Apr 19 01:00:45 main postfix/qmgr[3879]: BF191704020: from=<admispconfig@tech-xpress.com>, size=610, nrcpt=1 (queue active)
    Apr 19 01:00:45 main postfix/qmgr[3879]: A2203704024: from=<>, size=2476, nrcpt=1 (queue active)
    Apr 19 01:00:46 main postfix/smtp[2524]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 01:00:46 main postfix/smtp[2525]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 01:00:46 main postfix/smtp[2526]: connect to tech-xpress.com[209.193.68.93]: Connection refused (port 25)
    Apr 19 01:00:46 main postfix/smtp[2524]: 534F270401D: to=<root@tech-xpress.com>, orig_to=<root>, relay=none, delay=400918, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 01:00:46 main postfix/smtp[2526]: A2203704024: to=<admispconfig@tech-xpress.com>, relay=none, delay=386821, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    Apr 19 01:00:46 main postfix/smtp[2525]: BF191704020: to=<support@tech-xpress.com>, relay=none, delay=391321, status=deferred (connect to tech-xpress.com[209.193.68.93]: Connection refused)
    
    There's the last several lines of the mail servers log. I suck at understanding log files so excuse me if I've looked over the problem like an idiot. I post this because I don't believe it's my OE setup but rather the server config that I've messed up somewhere. Just really not sure where. And I have already read through and followed the instructions on the websites documentation and that has gotten me no where so far. I am unable to see where I may have and or did miss configure things. Any further help would be much appreciated as always, thanks.
     
  10. till

    till Super Moderator

    tech-xpress.com is not your local server?

    Then check your firewall and ask your provider if they allow connections on port 25.
     
  11. Duplex

    Duplex New Member

    Tech-Xpress.com is a site on the ISPconfig box I have running, I have setup several emails on it. Port 25 has NEVER EVER been blocked by provider or firewall. It's obviously showing on the server which means it has gotten all the way there.

    I have outlook express configured with sever accounts all on different non local servers. I used one of those accounts to send an email to support@tech-xpress.com to admin@tech-xpress.com. It then went out from my computer through my router to my ISP into their servers then got the MX records went through my router into the ISPconfig server and the connection was refused at that point. What I find strange is that I can do a telnet to the server on the same port and it works fine. not a telnet localhost 25 but rather a telnet 192.168.1.4 25. I haven't been away from home lately but if I get outside my network in the next day or two I'll try a telnet from telnet 209.193.68.93 25 and see what happens.

    *note: I used to work at my current ISP so I know their setup.
     
  12. falko

    falko Super Moderator

    I can connect to tech-xpress.com without problems:

    Code:
    telnet tech-xpress.com 25
    Trying 209.193.68.93...
    Connected to 41850.dsl.gill.wy.vcn.com.
    Escape character is '^]'.
    220 main.tech-xpress.com ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250-main.tech-xpress.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    quit
    221 Bye
    Connection closed by foreign host.
    Is 209.193.68.93 your public IP address? Is your server in a local network behind a router? What's in /etc/postfix/main.cf?
     

Share This Page