email returned: domain does not resolve

Discussion in 'Installation/Configuration' started by drmeg, Jan 3, 2007.

  1. drmeg

    drmeg New Member

    Some of my emails are being returned with the following message:

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <[email protected]>: host mx.us.army.mil[143.69.243.34] said: 451 #4.1.8
    Domain of sender address <[email protected]> does not resolve (in reply to
    MAIL FROM command)

    Email that I send to military addresses is returned undelivered after about 5 days. Email that I send to hotmail addresses is dumped into their junk folders.

    I am running ispconfig 2.2.9 on ubuntu 6.06.
    Any ideas?

    drmeg
     
    Last edited: Jan 3, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that the nameserver of the domain cslive.net is not responding:

    dig cslive.net

    ; <<>> DiG 9.2.1 <<>> cslive.net
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    Please make sure that the authoritive nameserver for the domain is reachable.
     
  3. drmeg

    drmeg New Member

    Till -
    Thanks for your quick response.
    When I run the dig command, I get the following:

    ; <<>> DiG 9.3.2 <<>> cslive.net
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33523
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;cslive.net. IN A

    ;; ANSWER SECTION:
    cslive.net. 86400 IN A 71.48.160.227

    ;; AUTHORITY SECTION:
    cslive.net. 86400 IN NS ws1.cslive.net.

    ;; ADDITIONAL SECTION:
    ws1.cslive.net. 121713 IN A 71.48.160.227

    ;; Query time: 118 msec
    ;; SERVER: 192.168.2.1#53(192.168.2.1)
    ;; WHEN: Wed Jan 3 20:28:34 2007
    ;; MSG SIZE rcvd: 78

    Perhaps I am having some sort of intermittent connectivity problem. Is there some way to check that?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you run the dig command on the same server where the BIND server is running, you will query the local server. But its good to know that your local server is answering correctly.

    Have you specified your local server as authoritive nameserver for cslive.net at your domain registrar?
     
  5. drmeg

    drmeg New Member

    Yes - as far as I know.

    My domain name (cslive.net) and my dns server (ws1.cslive.net) are registered with godaddy.com. I have spoken with the registrar, and they tell me that since I am running my own dns server, the error must be in my configuration - and they cannot help.

    I have been querying a few different dns servers (using a site called www.kloth.net), and I seem to get good results from these:

    ns1.sprintlink.net
    vnsc-bak.sys.gtei.net
    ns.oneworldhosting.com

    However, the default dns server at kloth.net is unable to reach mine.
    So I am really confused.

    Thanks.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess your problem is the common hen <==> egg problem :) You can not run the nameserver for a domain (cslive.net) on its own subdomain (ws1.cslive.net). To solve this, you need another domain (technical domain) poibting to your server that you can use as nemserver setting for cslive.net at godaddy.
     
  7. drmeg

    drmeg New Member

    Till -

    Actually, ws1 is the name of my server, and so ws1.cslive.net is supposed to be my server's FQDN. I must have messed something up, but I don't know what.

    And I might add that I have several websites on this server which all seem to work properly, and most of my emails send/receive correctly. Only a few are returned with that 'does not resove' error, and these appear to all be U.S. military email addresses.

    Thanks for taking the time to help me with this.
     
    Last edited: Jan 8, 2007
  8. falko

    falko Super Moderator ISPConfig Developer

  9. drmeg

    drmeg New Member

    Falko and Till -

    Thanks for the ideas. I re-read Falko's tutorial, How To Run Your Own Name Servers With ISPConfig And GoDaddy, and followed it exactly (except that my ns1 and ns2 both point to the same ip address at the moment). I had to have help from GoDaddy tech support in order to gain access to Total DNS Control because it was unavailable until I selected the option to use the default parked nameservers.

    Everything seems to be working now. The parked nameserver solves the circular reference issue, and I think my setup now matches the erikturk.com example. Please let me know if I missed something.

    The amazing thing is that I did not know there was a problem -- all of my hosted websites have been accessible for a couple of months (at least from the locations from which I tried to access them). I guess this is a symptom of the circular reference. I've learned a lot in the last few days about dns - and still don't know very much. :eek:

    Thanks again to both of you for your help.
     

Share This Page